Bug 43013 - No mention of limitation regarding deployment with multi-level context paths (e.g. /123/456)
No mention of limitation regarding deployment with multi-level context paths ...
Status: RESOLVED DUPLICATE of bug 44021
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Manager
5.5.23
Other other
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 43014 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-08-02 02:53 UTC by d.alexander
Modified: 2008-05-05 11:17 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description d.alexander 2007-08-02 02:53:54 UTC
If I understand correctly, the manager app doesn't support deployment with
multi-level context paths e.g. path="/123/456".

I couldn't see any mention of this limitation in the docs. Would be useful if it
was mentioned there.

Also, if trying to do this, the deployment fails but with no explanation. It
should be simple to add a test for multi-level paths and exit with an
appropriate error message, e.g.

Inserting after this block from org.apache.catalina.manager.ManagerServlet

        // Validate the requested context path
        if ((path == null) || path.length() == 0 || !path.startsWith("/")) {
            writer.println(sm.getString("managerServlet.invalidPath", path));
            return;
        }

the following code at line 588:

        if (path.lastIndexOf("/") > 0) {
            writer.println(sm.getString("managerServlet.unsupportedPath", path));
            return;
        }

Adding appropriate messages to properties files of course.


It would be even better if the manager could deploy apps using such a context
path but that would be an enhancement so I'll request that separately.
Comment 1 Remy Maucherat 2007-08-02 04:09:45 UTC
*** Bug 43014 has been marked as a duplicate of this bug. ***
Comment 2 Mark Thomas 2008-05-05 11:17:51 UTC
This will be fixed by implementing the enhancement in bug44021 so marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 44021 ***