Bug 43944 - org.apache.el.lang.ELArithmetic.coerce throws MissingResourceException for key el.convert
org.apache.el.lang.ELArithmetic.coerce throws MissingResourceException for ke...
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Servlet & JSP API
6.0.14
Other other
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-11-22 19:23 UTC by Thai Ha
Modified: 2007-12-28 13:22 UTC (History)
0 users



Attachments
Sample project to duplicate the defect (4.14 KB, application/x-zip-compressed)
2007-11-22 19:28 UTC, Thai Ha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thai Ha 2007-11-22 19:23:45 UTC
The class org.apache.el.lang.ELArithmetic
has the following code snippet:

throw new IllegalArgumentException(MessageFactory.get("el.convert", obj, 
objType));

But the key "el.convert" doesn't exist in "org.apache.el.Messages". As a 
result, I'm receiving the exception:
java.util.MissingResourceException: Can't find resource for bundle 
java.util.PropertyResourceBundle, key el.convert
	at java.util.ResourceBundle.getObject(ResourceBundle.java:325)
	at java.util.ResourceBundle.getString(ResourceBundle.java:285)
	at org.apache.el.util.MessageFactory.getArray(MessageFactory.java:67)
	at org.apache.el.util.MessageFactory.get(MessageFactory.java:47)
	at org.apache.el.lang.ELArithmetic.coerce(ELArithmetic.java:367)
	at org.apache.el.lang.ELArithmetic.add(ELArithmetic.java:238)
	at org.apache.el.parser.AstPlus.getValue(AstPlus.java:24)
	at org.apache.el.ValueExpressionImpl.getValue
(ValueExpressionImpl.java:186)
Comment 1 Thai Ha 2007-11-22 19:28:28 UTC
Created attachment 21176 [details]
Sample project to duplicate the defect

To duplicate the defect:
1. Download jar files:
http://repo1.maven.org/maven2/org/apache/tomcat/el-api/6.0.14/el-api-6.0.14.jar
and
http://repo1.maven.org/maven2/org/apache/tomcat/jasper-el/6.0.14/jasper-el-6.0.14.jar

2. Open project in Eclipse, correct the references to el-api-6.0.14.jar and
jasper-el-6.0.14.jar by the new downloaded files
3. Run the App class, the exception will be displayed
Comment 2 Mark Thomas 2007-12-24 07:55:42 UTC
Fixed in trunk. Proposed for 6.0.x
Comment 3 Mark Thomas 2007-12-28 13:22:21 UTC
This has been fixed in svn and will be included in 6.0.16 onwards.