Bug 44011 - Result tree : "Response Data" panel is empty on SOAP/XML-RPC sampler
Result tree : "Response Data" panel is empty on SOAP/XML-RPC sampler
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.3.1
PC Windows XP
: P2 regression with 1 vote (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 44273 44552 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-12-03 04:44 UTC by David Langlais
Modified: 2008-04-28 07:09 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Langlais 2007-12-03 04:44:03 UTC
After executing SOAP/XML-RPC Sampler, the result tree panel named 'response
data' appears deactivated. No data are present for human test result examination.

Viewed on : Windows XP SP2 JRE 1.6.0_03 JMeter 2.3.1
Comment 1 Sebb 2007-12-03 05:34:10 UTC
What does the Sampler Result pane show for the Content-Type under Response 
Headers?

Unless the type is recognised as a text type, it won't be displayable as text.
Comment 2 David Langlais 2007-12-03 06:49:07 UTC
(In reply to comment #1)
> What does the Sampler Result pane show for the Content-Type under Response 
> Headers?
> 
> Unless the type is recognised as a text type, it won't be displayable as text.

It looks like this :

Response headers:
HTTP/1.1 200 OK
Date: Mon, 03 Dec 2007 14:31:42 GMT
Server: Apache/2.0.49 (Unix)
Content-Length: 3176
Connection: close
Content-Type: application/soap+xml

(SOAP messages are tagged with 'application/soap+xml' in accordance to W3C's
recommandations
http://www.w3.org/TR/2007/REC-soap12-part2-20070427/#httpmediatype)
Comment 3 Sebb 2007-12-03 07:43:45 UTC
Try adding the following JMeter property:

content-type_text=application/soap+xml

to jmeter.properties or user.properties (or on the command-line)
Comment 4 Sebb 2007-12-03 07:50:23 UTC
I've added application/soap+xml as a text type in SVN r600573
Comment 5 Jeroen Borgers 2008-01-04 07:45:54 UTC
I got application/xml type returned and encountered the same problem in version
3.2.1. It worked flawlessly in 3.2. Please also add application/xml.
Comment 6 Sebb 2008-01-09 09:11:25 UTC
(In reply to comment #5)
> I got application/xml type returned and encountered the same problem in 
version
> 3.2.1. It worked flawlessly in 3.2. Please also add application/xml.

Fixed in r610461
Comment 7 Sebb 2008-01-21 01:41:10 UTC
*** Bug 44273 has been marked as a duplicate of this bug. ***
Comment 8 Sebb 2008-03-02 15:58:22 UTC
The change in 2.3.1 has caused quite a few problems, so the next release of JMeter will revert to the previous behaviour.
Comment 9 Sebb 2008-03-06 15:39:56 UTC
*** Bug 44552 has been marked as a duplicate of this bug. ***
Comment 10 Sebb 2008-04-22 06:38:16 UTC
*** Bug 44852 has been marked as a duplicate of this bug. ***
Comment 11 Sebb 2008-04-28 07:09:44 UTC
(In reply to comment #10)
> *** Bug 44852 has been marked as a duplicate of this bug. ***
> 

That was incorrect; Bug 44852 is not a duplicate.