Bug 44042 - Regression in Cookie Manager
Regression in Cookie Manager
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
2.3.1
Other other
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 44043 44228 44763 44814 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-12-07 16:06 UTC by Przemyslaw Jaskierski
Modified: 2008-04-13 04:55 UTC (History)
4 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Przemyslaw Jaskierski 2007-12-07 16:06:37 UTC
In version 2.2 this works: when Http client samplers and Cookie Manager with
"clear cookies each iteration" enabled are put into thread group, for 20 thread
running concurrently in that group there are 20 different HTTP sessions
initialized for every iteration, dropped at the end of this iteration.

In 2.3.1 for the same script only ONE http session is created for all 20 threads
and it's not dropped on every iteration.
Comment 1 Sebb 2007-12-07 18:31:26 UTC
Also works in 2.3 (or maybe that's what you meant?).

The collection used to store the permanent cookies was being shared between 
threads, instead of copied - oops!

Fixed in SVN r602290.

Thanks for the report.
Comment 2 Przemyslaw Jaskierski 2007-12-07 18:36:53 UTC
Woow, that was quick :)

Thank you.
Comment 3 Sebb 2007-12-07 19:39:04 UTC
If you want to try the fix, it's in the nightly r602302.

Let us know if there are any problems.
Comment 4 Sebb 2007-12-08 05:28:20 UTC
*** Bug 44043 has been marked as a duplicate of this bug. ***
Comment 5 Sebb 2008-01-14 09:03:22 UTC
*** Bug 44228 has been marked as a duplicate of this bug. ***
Comment 6 Sebb 2008-01-14 09:05:19 UTC
See:

http://markmail.org/message/bis6om3wnpqtqin5

for additional work-rounds
Comment 7 Hervé Rolland 2008-04-07 01:52:30 UTC
*** Bug 44763 has been marked as a duplicate of this bug. ***
Comment 8 Sebb 2008-04-13 04:55:53 UTC
*** Bug 44814 has been marked as a duplicate of this bug. ***