Bug 44075 - org.apache.poi.hslf.usermodel.SlideShow fails when there are multiple master slides
Summary: org.apache.poi.hslf.usermodel.SlideShow fails when there are multiple master ...
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: HSLF (show other bugs)
Version: 3.0-FINAL
Hardware: All Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-13 11:06 UTC by todd sharp
Modified: 2007-12-18 05:54 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description todd sharp 2007-12-13 11:06:08 UTC
org.apache.poi.hslf.usermodel.SlideShow fails when there are multiple master slides

Stack trace:

Caused by: java.lang.ClassCastException: org.apache.poi.hslf.record.Slide cannot
be cast to org.apache.poi.hslf.record.MainMaster
	at org.apache.poi.hslf.usermodel.SlideShow.buildSlidesAndNotes(SlideShow.java:320)
	at org.apache.poi.hslf.usermodel.SlideShow.<init>(SlideShow.java:121)
	... 39 more
Comment 1 Nick Burch 2007-12-17 03:15:07 UTC
Hmm, I thought we did handle multiple master slides properly, but I'm guessing
there's a flaw somewhere.

Can you upload the problem file, so we can see what needs sorting out?
Comment 2 todd sharp 2007-12-18 05:54:35 UTC
I'm terribly sorry I was using an old version.  I upgraded to the most recent
version and everything works fine now.  Thank you.