Bug 44094 - privileged="true" causes ClassNotFound from shared\lib
privileged="true" causes ClassNotFound from shared\lib
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.5.17
PC Windows Server 2003
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 39589 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-12-18 10:54 UTC by john deardurff
Modified: 2009-01-03 14:53 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john deardurff 2007-12-18 10:54:12 UTC
By adding the privileged="true" attribute to the Context element of some
conf\Catalina\localhost\myApp.xml as in:

<Context path="/myApp" docBase="C:/myApp/" cookies="false" override="true"
privileged="true">

Jar files within shared\lib are no longer loaded for the myApp application, but
jars from common\lib are. 

We are using Tomcat 5.5.17 with JRE 5.5_06 running on Windows and AIX servers.
The problem is consistently reproducible. 

For us the temporary workaround has been to move our shared jars from shared\lib
to common\lib.
Comment 1 Mark Thomas 2007-12-18 14:54:53 UTC
Sorry, the docs should have made the change in parent class loader as a result
of using this option clear. I have updated the docs for trunk and proposed the
change for inclusion in 6.0.x and 5.5.x.
Comment 2 Mark Thomas 2007-12-23 12:04:51 UTC
Fixed in 6.0.x.
Comment 3 Mark Thomas 2008-01-06 15:13:19 UTC
Fixed in 5.5.x and will be included in 5.5.26 onwards.
Comment 4 Konstantin Kolinko 2009-01-03 14:53:43 UTC
*** Bug 39589 has been marked as a duplicate of this bug. ***