Bug 44124 - hyphenation-character doesn't appear in pdf
Summary: hyphenation-character doesn't appear in pdf
Status: CLOSED DUPLICATE of bug 38264
Alias: None
Product: Fop - Now in Jira
Classification: Unclassified
Component: pdf (show other bugs)
Version: 0.94
Hardware: Other other
: P2 normal
Target Milestone: ---
Assignee: fop-dev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-21 15:25 UTC by Xuan Ngo
Modified: 2012-04-01 13:50 UTC (History)
0 users



Attachments
All files need to reproduce the issue. (8.44 KB, application/octet-stream)
2007-12-21 15:26 UTC, Xuan Ngo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xuan Ngo 2007-12-21 15:25:14 UTC
Right, as soon as you enable white-space-treatment="preserve" the
hyphenation-character is just ignored. Otherwise, the hyphenation
character works fine. Can you please open an issue in Bugzilla and add
your files there? We'll have to look into this.
http://issues.apache.org/bugzilla/

Unfortunately, I could not come up with a work-around.

On 20.12.2007 21:37:19 Xuan Ngo wrote:
> I tried to change the hyphenation-character with a backslash in 
<programlisting> tag but it is
 not
> appearing in the pdf output. However, long line in pdf are broken down to 
multiple lines.
> Can some1 tell me what is wrong with my customization layer?
> I'm using Docbook 1.73.2 and FOP v0.94.
> 
> Here is my customization layer:
>     <xsl:param name="hyphenate.verbatim" select="1"></xsl:param>
>     
>     <xsl:attribute-set name="monospace.verbatim.properties"
> use-attribute-sets="verbatim.properties monospace.properties">
>       <xsl:attribute name="wrap-option">wrap</xsl:attribute>
>       <xsl:attribute name="hyphenation-character">\</xsl:attribute>
>     </xsl:attribute-set>
> 
> I also attach all required files in case that they are needed.
> 
> thx!
>
Comment 1 Xuan Ngo 2007-12-21 15:26:31 UTC
Created attachment 21302 [details]
All files need to reproduce the issue.
Comment 2 Andreas L. Delmelle 2007-12-24 01:30:33 UTC

*** This bug has been marked as a duplicate of 38264 ***
Comment 3 Glenn Adams 2012-04-01 13:50:42 UTC
batch transition to closed remaining pre-FOP1.0 resolved bugs