Bug 44234 - Not Showing Protected Directories in Indexes option
Summary: Not Showing Protected Directories in Indexes option
Status: RESOLVED INVALID
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.2.6
Hardware: Other Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2008-01-14 17:56 UTC by Prasul Surendran
Modified: 2008-01-24 12:38 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Prasul Surendran 2008-01-14 17:56:27 UTC
Hi,

We have found that while using the clause:

Options +Indexes 

on .htaccess file, it fails to display password protected directories. From what
it goes from our research is; the directory shows a forbidden flag when apache
tries to Index it. Please can you have this checked. 

For the current error we have used Options +ShowForbidden to have this
displayed, but please do check on why it doesn't get displayed during normal
operation of .htaccess. 

Thank you.

With Best Regards,

Prasul Surendran
Comment 1 Joshua Slive 2008-01-24 12:38:24 UTC
This is exactly as designed. Entries are not displayed unless they could be
browsed with the current credentials of the client.

You may be confused because ShowForbidden could be more-accurately named
ShowForbiddenOrUnathorized, but that would be too ugly.