Bug 44325 - JMeter converts new lines to spaces
Summary: JMeter converts new lines to spaces
Status: RESOLVED DUPLICATE of bug 51861
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: unspecified
Hardware: PC Windows XP
: P2 minor with 1 vote (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 28866 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-29 15:45 UTC by Dylan Lacey
Modified: 2011-12-28 13:14 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dylan Lacey 2008-01-29 15:45:35 UTC
A HTTP Sampler has a single parameter composed of several name=value pairs, each
on a new line:

name1=value1
name2=value2
name3=value3

In JMeter this shows up as a single parameter.  When the user attempts to edit
the parameter, JMeter allows it, but running the script subsequently shows that
Sample no longer makes the correct request.

Checking the script in a text editor shows that, when the user clicks in the
"value" field of the Sampler, the breaks are automatically converted to spaces.

name1=value1 name2=value2 name3=value3

This causes the system under test to treat the sampler's request as an erroneous
request.
Comment 1 Sebb 2008-01-31 04:56:19 UTC
See also Bug 28866.

The current behaviour is probably due to the use of the default Table Cell editor.
Comment 2 Sonam Chauhan 2008-03-19 18:30:35 UTC
*** Bug 28866 has been marked as a duplicate of this bug. ***
Comment 3 Sebb 2008-10-11 04:39:01 UTC
The next version of JMeter will have a __char() function which can be used to insert arbitrary characters into strings. This can be used as a work-round. The __char() function is available in current nightly builds.
Comment 4 Philippe Mouawad 2011-12-28 13:14:54 UTC
This issue is solved by the new feature in bug 51861.

Reopen if it's not the case.

*** This bug has been marked as a duplicate of bug 51861 ***