Bug 44685 - Base64 encoded value of cookie is not parsed correctly.
Summary: Base64 encoded value of cookie is not parsed correctly.
Status: RESOLVED DUPLICATE of bug 44679
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Connector:HTTP (show other bugs)
Version: 5.5.26
Hardware: PC Windows XP
: P1 critical (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-26 19:30 UTC by bryan
Modified: 2008-03-26 20:04 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bryan 2008-03-26 19:30:23 UTC
We are using base64 encoded cookie value. until upgrading tomcat5.5.26 everything works correctly. after upgrading if base64 encoded value contains pad('=') then parsed cookie value omits pad. that causes base64 parsing exception.

check this out please!
Comment 1 Filip Hanik 2008-03-26 20:04:26 UTC

*** This bug has been marked as a duplicate of bug 44679 ***