Bug 44717 - java.lang.ArrayIndexOutOfBoundsException ( hdgf : VisioTextExtractor )
Summary: java.lang.ArrayIndexOutOfBoundsException ( hdgf : VisioTextExtractor )
Status: RESOLVED DUPLICATE of bug 44501
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: unspecified
Hardware: Sun Solaris
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-31 14:39 UTC by Durga Deep Tirunagari
Modified: 2008-03-31 18:21 UTC (History)
0 users



Attachments
VisioTextExtractor extractor = null; extractor = new VisioTextExtractor(isr);convertedText = extractor.getText(); (205.00 KB, application/octet-stream)
2008-03-31 18:14 UTC, Durga Deep Tirunagari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Durga Deep Tirunagari 2008-03-31 14:39:07 UTC
ArrayIndexOutofBounndsException while indexing a VIsio Document ( Attached )


java.lang.ArrayIndexOutOfBoundsException: 1991
        at org.apache.poi.util.LittleEndian.getNumber(LittleEndian.java:502)
        at org.apache.poi.util.LittleEndian.getUInt(LittleEndian.java:164)
        at org.apache.poi.hdgf.chunks.ChunkHeader.createChunkHeader(ChunkHeader.java:43)
        at org.apache.poi.hdgf.chunks.ChunkFactory.createChunk(ChunkFactory.java:108)
        at org.apache.poi.hdgf.streams.ChunkStream.findChunks(ChunkStream.java:54)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:92)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:99)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:99)
        at org.apache.poi.hdgf.HDGFDiagram.<init>(HDGFDiagram.java:92)
        at org.apache.poi.hdgf.extractor.VisioTextExtractor.<init>(VisioTextExtractor.java:46)
        at org.apache.poi.hdgf.extractor.VisioTextExtractor.<init>(VisioTextExtractor.java:50)
Comment 1 Durga Deep Tirunagari 2008-03-31 18:14:39 UTC
Created attachment 21749 [details]
VisioTextExtractor extractor = null; extractor = new VisioTextExtractor(isr);convertedText = extractor.getText();



           VisioTextExtractor extractor = null;
           extractor = new VisioTextExtractor(isr);
           convertedText = extractor.getText();
Comment 2 Durga Deep Tirunagari 2008-03-31 18:21:14 UTC

*** This bug has been marked as a duplicate of bug 44501 ***