Bug 44781 - java.lang.IllegalArgumentException: Found a chunk with a negative length, which isn't allowed
Summary: java.lang.IllegalArgumentException: Found a chunk with a negative length, whi...
Status: RESOLVED DUPLICATE of bug 43670
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: unspecified
Hardware: Sun Solaris
: P1 critical with 6 votes (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-08 12:29 UTC by Durga Deep Tirunagari
Modified: 2010-06-03 07:15 UTC (History)
2 users (show)



Attachments
Visio File That fails. (205.00 KB, application/octet-stream)
2008-04-08 12:29 UTC, Durga Deep Tirunagari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Durga Deep Tirunagari 2008-04-08 12:29:18 UTC
Created attachment 21796 [details]
Visio File That fails.

WARNING: NameOfAttachment : LAB-01.CMPE.142_MIPS_Lab_with_SPIM_.ppt
Needed 19 bytes to create the next chunk header, but only found 5 bytes, ignoring rest of data
Needed 19 bytes to create the next chunk header, but only found 11 bytes, ignoring rest of data
Needed 19 bytes to create the next chunk header, but only found 5 bytes, ignoring rest of data
java.lang.IllegalArgumentException: Found a chunk with a negative length, which isn't allowed
        at org.apache.poi.hdgf.chunks.ChunkFactory.createChunk(ChunkFactory.java:112)
        at org.apache.poi.hdgf.streams.ChunkStream.findChunks(ChunkStream.java:58)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:92)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:99)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:99)
        at org.apache.poi.hdgf.HDGFDiagram.<init>(HDGFDiagram.java:92)
        at org.apache.poi.hdgf.extractor.VisioTextExtractor.<init>(VisioTextExtractor.java:47)
        at org.apache.poi.hdgf.extractor.VisioTextExtractor.<init>(VisioTextExtractor.java:51)
        at com.sun.comms.iss.indexapi.converter.MSVisioConverter.convertToText(MSVisioConverter.java:112)
        at com.sun.comms.iss.indexapi.converter.MSVisioConverter.getObject(MSVisioConverter.java:66)
        at com.sun.comms.iss.indexapi.converter.ConverterBase.getAttachmentObject(ConverterBase.java:31)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmailContent(CreateEmailDocument.java:416)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:302)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmailContent(CreateEmailDocument.java:450)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:511)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:278)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.createFromMessageObject(CreateEmailDocument.java:86)
        at com.sun.comms.iss.indexapi.crawler.EmailCrawler$FolderRunnable.run(EmailCrawler.java:276)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
        at java.lang.Thread.run(Thread.java:595)
Apr 8, 2008 12:27:52 PM com.sun.comms.iss.indexapi.converter.MSVisioConverter getObject
WARNING: Unable to Index MS Visio Document : Found a chunk with a negative length, which isn't allowed
Apr 8, 2008 12:27:52 PM com.sun.comms.iss.indexapi.converter.MSVisioConverter getObject
WARNING: Unable to Index MS Visio Document : Found a chunk with a negative length, which isn't allowed
java.lang.IllegalArgumentException: Found a chunk with a negative length, which isn't allowed
        at org.apache.poi.hdgf.chunks.ChunkFactory.createChunk(ChunkFactory.java:112)
        at org.apache.poi.hdgf.streams.ChunkStream.findChunks(ChunkStream.java:58)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:92)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:99)
        at org.apache.poi.hdgf.streams.PointerContainingStream.findChildren(PointerContainingStream.java:99)
        at org.apache.poi.hdgf.HDGFDiagram.<init>(HDGFDiagram.java:92)
        at org.apache.poi.hdgf.extractor.VisioTextExtractor.<init>(VisioTextExtractor.java:47)
        at org.apache.poi.hdgf.extractor.VisioTextExtractor.<init>(VisioTextExtractor.java:51)
        at com.sun.comms.iss.indexapi.converter.MSVisioConverter.convertToText(MSVisioConverter.java:112)
        at com.sun.comms.iss.indexapi.converter.MSVisioConverter.getObject(MSVisioConverter.java:66)
        at com.sun.comms.iss.indexapi.converter.ConverterBase.getAttachmentObject(ConverterBase.java:31)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmailContent(CreateEmailDocument.java:416)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:302)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmailContent(CreateEmailDocument.java:450)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:511)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:278)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.createFromMessageObject(CreateEmailDocument.java:86)
        at com.sun.comms.iss.indexapi.crawler.EmailCrawler$FolderRunnable.run(EmailCrawler.java:276)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
        at java.lang.Thread.run(Thread.java:595)
Comment 1 Nick Burch 2010-06-03 07:15:14 UTC

*** This bug has been marked as a duplicate of bug 43670 ***