Bug 44802 - MonitorHealthVisualizer.java enhancement
Summary: MonitorHealthVisualizer.java enhancement
Status: RESOLVED WONTFIX
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: unspecified
Hardware: PC Windows XP
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 44791 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-10 12:54 UTC by David Brown
Modified: 2016-02-21 22:13 UTC (History)
1 user (show)



Attachments
MonitorHealthVisualizer.java 3rd tabbed pane enhancement (76.05 KB, image/png)
2008-04-10 12:57 UTC, David Brown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Brown 2008-04-10 12:54:13 UTC
I have been using JMeter for some months. I have started out on the JMeter user ML mostly to get help with .jmx Samplers and Listeners and the usual sort of problems involved with learning JMeter as a user for testing and monitoring purposes. Notwithstanding, I have compiled the CVS trunk source (20080408). As a result I discovered a very nice feature enhancement suggested in the Comments in the Monitor Results Listener (MonitorHealthVisualizer.java). At the top of the class file: MonitorHealthVisualizer.java  it is stated: <In the future, we may want to add email alerts as a third tab>. Cutting to the chase I took the liberty of implementing the MailerVisualizer functionality as a JSplitPane and added it to the Monitor Results Listener. I have a .PNG screen-shot of the result. I have done no testing. I would like feedback on whether the Mailer Alerts tabbed pane looks as it should and if this is acceptable. If this is acceptable  I would like to complete the testing and learn what I need to do to get the source contributed to the JMeter project. Please find attached the screen-shot described above. Please advise, David.
Comment 1 David Brown 2008-04-10 12:57:46 UTC
Created attachment 21810 [details]
MonitorHealthVisualizer.java 3rd tabbed pane enhancement

This is a screen-shot of the results of deploying the MailerVisualizer.java functionality as the 3rd tabbed pane in the MonitorHealthVisualizer.java (Monitor Results Listener).
Comment 2 Sebb 2008-04-10 13:08:18 UTC
*** Bug 44791 has been marked as a duplicate of this bug. ***
Comment 3 Sebb 2009-01-29 10:54:29 UTC
Please don't assign bugs.
Comment 4 Philippe Mouawad 2016-02-21 22:13:48 UTC
There are better ways nowadays to monitor a Tomcat.
We have lot of work on JMeter so closing this one as WONTFIX