Bug 44882 - Feature Request mod_proxy sockettimeout
Summary: Feature Request mod_proxy sockettimeout
Status: RESOLVED DUPLICATE of bug 45445
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy (show other bugs)
Version: 2.5-HEAD
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2008-04-26 14:01 UTC by Michael Haas
Modified: 2009-10-28 14:17 UTC (History)
0 users



Attachments
patch to add sockettimeout parameter (6.13 KB, patch)
2008-04-26 14:01 UTC, Michael Haas
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Haas 2008-04-26 14:01:23 UTC
Created attachment 21859 [details]
patch to add sockettimeout parameter

Hello,

i would like to submit a feature request to add the possibility to specify a sockettimeout for Reverse Proxy. I know that this is not a necessary feature for normal Reverse Proxies but for a balancer configuration i think it is highly desirable.I already posted a question to the user-list about this and explained what would be nice to have as a feature (http://mail-archives.apache.org/mod_mbox/httpd-users/200803.mbox/%3C47D1EA54.BE70.0010.0@brz.gv.at%3E). I have tried to implement this into the latest trunk version and for me it has worked, but i'm not a programmer (copied mostly only the timeout code) so maybe i did something really stupid. I only tried it with http protocol.

Here is the test configuraton i used

<VirtualHost xx.xx.xx.xx:8888>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "/home/xxx/htdocs"
    ServerName xx.xx.xx.xx
    ProxyRequests Off
    ProxySocketTimeout 60
    <Proxy *>
    Order deny,allow
    Allow from all
    </Proxy>
    <Proxy balancer://mycluster>
    BalancerMember http://xx.xxx.xx.xx1:9000 timeout=90 retry=420
    BalancerMember http://xx.xxx.xx.xx2/cgi-bin/test-markus sockettimeout=15 timeout=90 retry=420
    </Proxy>
    ProxyPass /em !
    ProxyPass /j2ee !
    ProxyPass /server-status !
    ProxyPass / balancer://mycluster/
    ProxyPassReverse / http://xx.xxx.xx.xx1/
    ProxyPassReverse / http://xx.xxx.xx.xx1:9000/
    ProxyPassReverse / http://xx.xxx.xx.xx2/cgi-bin/test-markus
    ProxyPassReverse / http://xx.xxx.xx.xx1:80/cgi-bin/test-markus
    ProxyPreserveHost On
    ProxyStatus On

    ErrorLog "logs/dummy-host.example.com-error_log"
    CustomLog "logs/dummy-host.example.com-access_log" common
</VirtualHost>


Thanks for your attention
Michael
Comment 1 Michael Haas 2009-10-28 14:17:57 UTC
implemented with Bug 45445

*** This bug has been marked as a duplicate of bug 45445 ***