Bug 44998 - PPT Saved from Open Office Can Not Be Converted
Summary: PPT Saved from Open Office Can Not Be Converted
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: HSLF (show other bugs)
Version: unspecified
Hardware: PC Windows Vista
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-14 09:53 UTC by todd sharp
Modified: 2008-05-15 05:43 UTC (History)
0 users



Attachments
ppt saved from open office (146.00 KB, application/vnd.ms-powerpoint)
2008-05-14 09:53 UTC, todd sharp
Details
Output from PowerPointExtractor (3.05 KB, text/plain)
2008-05-14 23:11 UTC, Yegor Kozlov
Details
Output from sample java code (3.30 KB, text/plain)
2008-05-14 23:11 UTC, Yegor Kozlov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description todd sharp 2008-05-14 09:53:51 UTC
Created attachment 21961 [details]
ppt saved from open office

I have a PPT that I save as PPT 97/2000 from within open office.  When I do this on 3.1 beta i receive no slides back when I try to extract.  File attached.

The process worked fine on 3.0.2
Comment 1 Yegor Kozlov 2008-05-14 23:10:27 UTC
I can't reproduce the problem. I can open the attached file and extract text and shapes. Both PowerPointExtractor and sample Java code work fine to me.

 (1) org.apache.poi.hslf.extractor.PowerPointExtractor sql-tips-string-concatenation.ppt 

The output is attached as PowerPointExtractor.txt

 (2) Sample Java code:

    public static void main(String[] args) throws Exception {
        SlideShow ppt = new SlideShow(new FileInputStream(args[0]));
        Slide[] slide = ppt.getSlides();
        for (int i = 0; i < slide.length; i++) {
            System.out.println("slide: " + slide[i].getSlideNumber());
            TextRun[] tx = slide[i].getTextRuns();
            for (int j = 0; j < tx.length; j++) {
                System.out.println("  " + tx[j].getText());
            }
        }
    }

The output is attached as HSLF-test.txt

Please try the latest svn trunk. Daily builds can be downloaded from 
http://encore.torchbox.com/poi-svn-build/

If you still have a problem, re-open this bug and attach a sample code to reproduce it.

Regards,
Yegor

Comment 2 Yegor Kozlov 2008-05-14 23:11:05 UTC
Created attachment 21964 [details]
Output from PowerPointExtractor
Comment 3 Yegor Kozlov 2008-05-14 23:11:25 UTC
Created attachment 21965 [details]
Output from sample java code
Comment 4 todd sharp 2008-05-15 05:43:36 UTC
Sorry about this bug report, it was something really weird happening with how I load POI in ColdFusion I think.