Bug 45046 - Cell References for Macro Function are moved after saving
Summary: Cell References for Macro Function are moved after saving
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.0-FINAL
Hardware: PC Windows XP
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-20 08:28 UTC by Bernhard
Modified: 2008-05-22 22:30 UTC (History)
0 users



Attachments
after saving this file some cell references from myfunction are pointing to a different cell (22.00 KB, application/vnd.ms-excel)
2008-05-20 08:28 UTC, Bernhard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard 2008-05-20 08:28:58 UTC
Created attachment 21984 [details]
after saving this file some cell references from myfunction are pointing to a different cell

If I open and store an xls-file (no changes) with hssf some cell references are moved to a different location. Only cell references from macro functions are affected.

I attached an example xls. After saving this file with poi some cell references point at a different cell. 

Build & Platform
poi-3.0.1-FINAL-20070705 on Win XP SP2
Comment 1 Josh Micich 2008-05-22 22:30:23 UTC
There were a few POI bugs that needed fixing here.

The initial report "some cell references point at a different cell" is probably a duplicate of bug 41726 (which was fixed before 3.0.2-FINAL.

However, since then the LinkTable has been abstracted and it had an assumption that NameRecord(DEFINEDNAME-0x18) would not occur by itself, but only after a SupBook(EXTERNALBOOK-0x1AE) and an ExternalSheet(EXTERNSHEET-0x17) record.

The supplied file just has a NameRecord all by itself, and Excel seems to be OK with this.  The fix was relatively simple and was applied in svn r659429.

There were much worse problems which were fixed separately in bug 45066.