Bug 45167 - Word - hwpf.table.getRow() return incorrect data
Summary: Word - hwpf.table.getRow() return incorrect data
Status: RESOLVED DUPLICATE of bug 45062
Alias: None
Product: POI
Classification: Unclassified
Component: HWPF (show other bugs)
Version: 3.0-FINAL
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-09 02:29 UTC by Thomas Martin
Modified: 2008-06-09 04:43 UTC (History)
0 users



Attachments
A simple table in a word document (24.00 KB, application/msword)
2008-06-09 02:29 UTC, Thomas Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Martin 2008-06-09 02:29:07 UTC
Created attachment 22099 [details]
A simple table in a word document

For any table embedded in a Word document , the function getRow() does not work properly.
Example (included in attachment):
A 3 X 2 table in a word document:

C1 C2 C3
C4 C5 C6

getRow().text return for both lines: 
"C1C2C3C4
C4C5C6"

So row data get from table is incorrect. (and also needs some filtering with chars).
Gives same problem for TableCell as it is part of TableRow.
Comment 1 Thomas Martin 2008-06-09 04:43:06 UTC

*** This bug has been marked as a duplicate of bug 45062 ***