Bug 45221 - WARNING: Unrecognized options: for known options
Summary: WARNING: Unrecognized options: for known options
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.2.9
Hardware: PC Linux
: P2 normal with 1 vote (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
: 45211 45243 45505 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-17 13:12 UTC by Igor Galić
Modified: 2008-11-07 09:23 UTC (History)
7 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Galić 2008-06-17 13:12:11 UTC
jmcg@Laptorix ~/tmp/httpd-2.2.9 % ./configure --prefix=${_prefix} \
                 \
                --localstatedir=${_localstate}/apache \
                --datadir=${_data}/apache \
                --libexecdir=${_libexec}/apache \
                --sysconfdir=${_sysconf}/apache \
                --with-ldap \
                --with-pcre=/usr \
                --with-program-name=httpd-worker --with-mpm=worker \
             --with-included-apr \
             --enable-mods-shared="all ssl ldap cache proxy authn_alias mem_cache file_cache authnz_ldap charset_lite dav_lock disk_cache"  | ack -i warning
configure: WARNING: Unrecognized options: --with-ldap
configure: WARNING: Unrecognized options: --with-ldap, --with-pcre, --with-program-name, --with-mpm, --with-included-apr, --enable-mods-shared
config.status: WARNING:  'apr-config.in' seems to ignore the --datarootdir setting
configure: WARNING: Unrecognized options: --with-ldap, --with-pcre, --with-program-name, --with-mpm, --with-included-apr, --enable-mods-shared
configure: WARNING: Unrecognized options: --with-pcre, --with-program-name, --with-mpm, --with-included-apr, --enable-mods-shared
configure: WARNING: Unrecognized options: --with-pcre, --with-program-name, --with-mpm, --with-included-apr, --enable-mods-shared
configure: WARNING: Unrecognized options: --with-ldap

This seems to be a regression issue, as I cannot reproduce it with the 2.2.8 tar ball:
jmcg@Laptorix ~/tmp/httpd-2.2.8 % ./configure --prefix=${_prefix} \
                 \
                --localstatedir=${_localstate}/apache \
                --datadir=${_data}/apache \
                --libexecdir=${_libexec}/apache \
                --sysconfdir=${_sysconf}/apache \
                --with-ldap \
                --with-pcre=/usr \
                --with-program-name=httpd-worker --with-mpm=worker \
             --with-included-apr \
             --enable-mods-shared="all ssl ldap cache proxy authn_alias mem_cache file_cache authnz_ldap charset_lite dav_lock disk_cache"  | ack -i warning
config.status: WARNING:  apr-config.in seems to ignore the --datarootdir setting
Comment 1 Igor Galić 2008-06-17 13:20:27 UTC
I'm getting a similar effect (for both, 2.2.9 and 2.2.8) by running ./buildconf prior to ./configure. You can find the output of ./buildconf itself here: http://nopaste.ch/en/db413dc3443222b.txt

(Initially I planned opening up a separate bug for the ./buildconf issue, but they are probably very related)

jmcg@Laptorix ~/tmp/httpd-2.2.9 % ./configure --prefix=${_prefix} \
          as above | ack -i warning
configure: WARNING: Unrecognized options: --with-ldap
configure: WARNING: Unrecognized options: --with-ldap, --with-pcre, --with-program-name, --with-mpm, --with-included-apr, --enable-mods-shared
/home/jmcg/tmp/httpd-2.2.9/srclib/apr/configure: line 9951: syntax error near unexpected token `lt_decl_varnames,'
/home/jmcg/tmp/httpd-2.2.9/srclib/apr/configure: line 9951: `lt_if_append_uniq(lt_decl_varnames, SED, , ,'
Comment 2 Ruediger Pluem 2008-06-17 13:39:04 UTC
Sorry but I don't get your issue right now. Is it about the WARNINGs itself? These are harmless and can be ignored. If you are using an older version of autoconf and call buildconf before configure they go away. So this is an autoconf problem. Regarding the second issue I cannot reproduce it and I guess it is a broken tool chain on your local box.
Comment 3 Nick Kew 2008-06-17 14:53:26 UTC
I think something has changed in 2.2.9.  It's been giving me a couple of spurious warnings, though nowhere near as much as reported here.  But I'll have to double-check I'm not confusing it with a build from trunk or 2.2.x SVN.

jMCg - bug me if I haven't followed up in a week or two.
Comment 4 Renata Rocha 2008-06-18 10:55:32 UTC
(In reply to comment #3)
> I think something has changed in 2.2.9.  It's been giving me a couple of
> spurious warnings, though nowhere near as much as reported here.  But I'll have
> to double-check I'm not confusing it with a build from trunk or 2.2.x SVN.
> 
> jMCg - bug me if I haven't followed up in a week or two.
> 

I'd like to know if the with-ldap option has been removed. I've been trying to compile apache 2.2.9 with --enable-authnz-ldap and it asks me to enable the --with-ldap option. But when I turn it on, I receive a message saying this option is not recognized. 
Comment 5 Ruediger Pluem 2008-06-18 12:01:01 UTC
(In reply to comment #4)
 
> 
> I'd like to know if the with-ldap option has been removed. I've been trying to
> compile apache 2.2.9 with --enable-authnz-ldap and it asks me to enable the
> --with-ldap option. But when I turn it on, I receive a message saying this
> option is not recognized. 
> 

Don't care about the warning. --with-ldap is still there and still needed in your case.

Comment 6 Renata Rocha 2008-06-18 12:41:36 UTC
(In reply to comment #5)
> (In reply to comment #4)
> 
> > 
> > I'd like to know if the with-ldap option has been removed. I've been trying to
> > compile apache 2.2.9 with --enable-authnz-ldap and it asks me to enable the
> > --with-ldap option. But when I turn it on, I receive a message saying this
> > option is not recognized. 
> > 
> 
> Don't care about the warning. --with-ldap is still there and still needed in
> your case.
> 

Yeah, and running ./buildconf removed the warnings. Thanks. 
Comment 7 Takashi Sato 2008-06-18 17:07:51 UTC
Very confusing. 
I propose to release 2.2.9-r2 or 2.2.10.
Comment 8 Takashi Sato 2008-06-19 19:33:57 UTC
*** Bug 45211 has been marked as a duplicate of this bug. ***
Comment 9 Nick Kew 2008-06-20 04:52:27 UTC
*** Bug 45243 has been marked as a duplicate of this bug. ***
Comment 10 Björn Wiberg 2008-07-22 00:30:37 UTC
On some machines at our site, we even get:

configure: WARNING: Unrecognized options: --enable-authn-alias, --enable-authnz-ldap, --enable-cache, --enable-charset-lite, --enable-dav-lock, --enable-disk-cache, --enable-file-cache, --enable-ldap, --enable-me
m-cache, --enable-mods-shared, --enable-proxy, --enable-proxy-ajp, --enable-proxy-balancer, --enable-proxy-connect, --enable-proxy-ftp, --enable-proxy-http, --enable-ssl, --with-dbm, --with-gdbm, --with-ldap, --w
ith-ldap-include, --with-ldap-lib, --with-mpm
Comment 11 Serge Knystautas 2008-08-02 14:44:16 UTC
I have downloaded 2.2.8 and 2.2.9 to the same machine, used the same configure line... worked for 2.2.8, config failed for 2.2.9.

Here is my configure line:

./configure --prefix=/usr/local/apache --with-mpm=worker --enable-nonportable-atomics=yes --enable-cache --enable-disk-cache --enable-deflate --enable-proxy --enable-proxy-http --enable-proxy-balancer --enable-rewrite --enable-headers --enable-info --enable-ssl

Like I said, this configured (and built fine) in 2.2.8, and the error message when this is configured on 2.2.9 is:

...
config.status: creating build/rules.mk
config.status: creating build/pkg/pkginfo
config.status: creating build/config_vars.sh
config.status: creating include/ap_config_auto.h
config.status: include/ap_config_auto.h is unchanged
config.status: executing default commands
configure: WARNING: Unrecognized options: --enable-nonportable-atomics

If you need me to attach the entire output of the configure script, let me know.

My result exactly fits [Bug-45243] which was marked a duplicate of this bug, so I'm included this report here.
Comment 12 Geert Wirken 2008-08-06 01:30:21 UTC
I get the following warning:
WARNING: Unrecognized options: --enable-rewrite, --enable-ssl, --enable-dav, --enable-dav-fs, --enable-so, --enable-vhost-alias, --with-ssl, --with-included-apr

My configure line (which worked fine for 2.2.8 and 2.2.7) is:
./configure --enable-rewrite --enable-ssl --enable-dav --enable-dav-fs --enable-so --enable-vhost-alias --with-ssl --with-included-apr

Doesn't look like a very exciting configure command to me...
Comment 13 Ruediger Pluem 2008-10-16 01:48:55 UTC
*** Bug 45505 has been marked as a duplicate of this bug. ***
Comment 14 Geert Wirken 2008-11-07 05:57:21 UTC
I don't know if things are changed for the 2.2.10 release, but I don't get these strange errors anymore using the same configure line. I guess it's fixed :)
Comment 15 Takashi Sato 2008-11-07 08:33:35 UTC
Thanks for reminder.
Comment 16 Ruediger Pluem 2008-11-07 09:23:19 UTC
It is.