Bug 45233 - Userdefined Data Validation Formula breaks after saveing with hssf
Summary: Userdefined Data Validation Formula breaks after saveing with hssf
Status: RESOLVED DUPLICATE of bug 45091
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.0-dev
Hardware: PC Windows XP
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-19 01:40 UTC by Bernhard
Modified: 2008-06-19 09:23 UTC (History)
0 users



Attachments
cell reference from the data validation formula is set to a1 after saving (13.50 KB, application/vnd.ms-excel)
2008-06-19 01:40 UTC, Bernhard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard 2008-06-19 01:40:31 UTC
Created attachment 22140 [details]
cell reference from the data validation formula is set to a1 after saving

If a user defined data validation uses cell-references in the formula, the reference points to the cell a1 after saving the excel file with poi.

Look at the attachment: After saving the file with poi the data validation from cell B4 changed from =TAG(B4)=1 to =TAG(A1)=1
Comment 1 Josh Micich 2008-06-19 09:23:02 UTC
This looks very similar to bug 45091
Please re-test with latest svn trunk / nightly build
(for example: http://encore.torchbox.com/poi-svn-build/poi-3.1-beta3-20080619.jar)

Reopen this bugzilla if the problem still occurs.

*** This bug has been marked as a duplicate of bug 45091 ***