Bug 45323 - Documentation doesn't specify that each context.xml may only contain one <Context/> element
Documentation doesn't specify that each context.xml may only contain one <Con...
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Documentation
Unknown
PC Linux
: P2 minor (vote)
: ---
Assigned To: Tomcat Developers Mailing List
http://tomcat.apache.org/tomcat-5.5-d...
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-07-01 23:05 UTC by Lars Kotthoff
Modified: 2008-07-06 13:08 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Kotthoff 2008-07-01 23:05:19 UTC
The documentation for configuring contexts (http://tomcat.apache.org/tomcat-5.5-doc/config/context.html) states that "You may define as many Context elements as you wish." However, it doesn't say that each context has to be defined in a different file.

This is especially confusing as putting more that one <Context/> element in a single context.xml file will give the error message "SEVERE: Parse error in context.xml" for each webapp with the exception message " The markup in the document following the root element must be well-formed." This indicates that the problem is with the XML syntax instead of the semantics of context definitions.
Comment 1 Mark Thomas 2008-07-06 13:08:02 UTC
I have added a note to the context docs which will be included in 5.5.27 onwards and 6.0.18 onwards.