Bug 45514 - Mac OS X Leopard 10.5.4 - Apache can't compile with mod_ssl
Summary: Mac OS X Leopard 10.5.4 - Apache can't compile with mod_ssl
Status: RESOLVED DUPLICATE of bug 44384
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.2.9
Hardware: Macintosh other
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2008-07-31 04:45 UTC by dgandra
Modified: 2008-08-06 07:59 UTC (History)
1 user (show)



Attachments
Configure and make logs (13.30 KB, application/x-zip-compressed)
2008-07-31 04:45 UTC, dgandra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dgandra 2008-07-31 04:45:50 UTC
Created attachment 22337 [details]
Configure and make logs

Apache 2.2.9 can't compile if module mod_ssl is enabled under Mac OS X 10.5.4.

   I made a lot of tries. The first one was with OpenSSL 0.9.7l (it cames with OS X 10.5.4) and then I tried with earlier versions, including the last one, OpenSSL 0.9.8h.


   The used ./configure directive was the following:

CC="darwin-i386-cc" LDFLAGS="-Llibdir"
./configure \
--enable-layout=Darwin \
--enable-mods-shared='all ssl dav cache proxy logio deflate cgi cgid suexec rewrite spelling expires' \
--with-ssl=/usr \
--with-included-apr \
--with-mpm=prefork


   The make process stopped after showing these lines:
...
/sources/httpd-2.2.9/srclib/apr/libtool --silent --mode=link gcc -g -O2     -L/usr/lib   -o ab  ab.lo    /sources/httpd-2.2.9/srclib/pcre/libpcre.la /sources/httpd-2.2.9/srclib/apr-util/libaprutil-1.la -lexpat -liconv /sources/httpd-2.2.9/srclib/apr/libapr-1.la -lpthread -lssl -lcrypto
Undefined symbols:
  "_BIO_set_callback_arg", referenced from:
      _start_connect in ab.o
  "_BIO_get_callback_arg", referenced from:
      _ssl_print_cb in ab.o
  "_SSL_CTX_set_info_callback", referenced from:
      _main in ab.o
  "_BIO_set_callback", referenced from:
      _start_connect in ab.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [ab] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1


  Using the following configure directive, the compiling and installation process is made successfully:

CC="darwin-i386-cc" LDFLAGS="-Llibdir"
./configure \
--enable-layout=Darwin \
--enable-mods-shared='all dav cache proxy logio deflate cgi cgid suexec rewrite spelling expires' \
--with-ssl=/usr \
--with-included-apr \
--with-mpm=prefork
Comment 1 Joe Orton 2008-08-06 07:59:58 UTC
This is a libtool bug.

in the MOD_SSL_LD_ADD line in build/config_vars.mk, delete the:

-export-symbols-regex ssl_module

from 

*** This bug has been marked as a duplicate of bug 44384 ***