Bug 45554 - poi-3.5-beta1-20080718.jar - content from an embedded document (docx, xlsx or pptx) of a 2007 docx document is not extracted.
Summary: poi-3.5-beta1-20080718.jar - content from an embedded document (docx, xlsx or...
Status: RESOLVED DUPLICATE of bug 45549
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: unspecified
Hardware: PC Windows Server 2003
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-05 05:41 UTC by xtrim
Modified: 2008-08-05 06:09 UTC (History)
0 users



Attachments
Contains JUnit test class and documents used for testing. (412.28 KB, application/x-zip-compressed)
2008-08-05 05:41 UTC, xtrim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xtrim 2008-08-05 05:41:05 UTC
Created attachment 22377 [details]
Contains JUnit test class and documents used for testing.

The text contained in a document embedded in a word 2007 document is not extracted (the embedded document may be a docx, a xlsx or a pptx document).
Find in attachments the JUnit test class and the documents used for testing.
We expected to extract the words "testdoc" and "test phrase".

Notes on the attached documents:

- the documents "classic_EmbeddedObject_word.docx" and "form_EmbeddedObject_word.docx" contain the words "testdoc" and "test phrase" in the embedded docx document.

- the documents "classic_EmbeddedObject_excel.docx" and "form_EmbeddedObject_excel.docx" contain the words "testdoc" and "test phrase" in the embedded xlsx document.

- the documents "classic_EmbeddedObject_ppt.docx" and "form_EmbeddedObject_ppt.docx" contain the words "testdoc" and "test phrase" in the embedded pptx document.



"TestUnitPoi35Filter.java" is the JUnit class.
Comment 1 Nick Burch 2008-08-05 06:09:23 UTC

*** This bug has been marked as a duplicate of bug 45549 ***