Bug 45560 - poi-3.5-beta1-20080718.jar - Office 2007 Word Template Format seems to be not supported.
Summary: poi-3.5-beta1-20080718.jar - Office 2007 Word Template Format seems to be not...
Status: RESOLVED DUPLICATE of bug 47517
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: unspecified
Hardware: PC Windows Server 2003
: P2 normal with 1 vote (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-05 07:36 UTC by xtrim
Modified: 2009-07-18 02:40 UTC (History)
0 users



Attachments
Contains JUnit test class and documents used for testing. (22.52 KB, application/x-zip-compressed)
2008-08-05 07:36 UTC, xtrim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xtrim 2008-08-05 07:36:43 UTC
Created attachment 22383 [details]
Contains JUnit test class and documents used for testing.

The Office 2007 Word Template Format 'dotx' seems to be not supported.
Find in attachments the JUnit test class and the document used for testing.
We expected to extract the words "testdoc" and "test phrase".

Notes on the attached documents:

- the document "classic_TemplateDocument.dotx" contains the words  "testdoc" and "test phrase" in the template document.


"TestUnitPoi35Filter.java" is the JUnit class.
Comment 1 Yegor Kozlov 2009-07-18 02:40:56 UTC
Fixed in r795327.
The fix added support the following files:

Microsoft Office Word 2007:

    * Word 2007 template(*.dotx)
    * Word 2007 macro-enabled document (*.docm)
    * Word 2007 macro-enabled template(*.dotm)

Microsoft Office Excel 2007:

    * Excel 2007 macro-enabled workbook (*.xlsm)
    * Excel 2007 template (*.xltx)
    * Excel 2007 macro-enabled template (*.xltm)
    * Excel 2007 add-in (*.xlam)


Regards,
Yegor

*** This bug has been marked as a duplicate of bug 47517 ***