Bug 45588 - Proxy error Reason: Error reading from remote server
Summary: Proxy error Reason: Error reading from remote server
Status: RESOLVED DUPLICATE of bug 37770
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy (show other bugs)
Version: 2.0.52
Hardware: PC Windows XP
: P2 blocker (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-07 07:34 UTC by Thierry
Modified: 2008-08-07 11:49 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry 2008-08-07 07:34:40 UTC
Good morning,
I have a problem on the web server and I do not know where this may come.
my application is running on the Apache server and redirects to tomcat on port 8080
Here is the apache configuration and error.


In the navigator

****************************************************
Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /scoreunity/gest.jsp
Reason: Error reading from remote server
****************************************************

kernel 2.6.9-34.Elsmp

apache 2.0.52
VirtualHost *:80>
ServerName 192.168.163.11

ProxyPass /test http://192.168.163.11:8080/test
ProxyPassReverse /test http://192.168.163.11:8080/test
SetEnv force-proxy-request-1.0 1
SetEnv proxy-nokeepalive 1

</VirtualHost>


tomcat 5.0.28
    <Connector port="8080"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="8443" acceptCount="100"
               debug="0" connectionTimeout="20000"
               disableUploadTimeout="true" />


thank you in advance for your answers
regards,
Comment 1 Ruediger Pluem 2008-08-07 11:49:27 UTC
Please upgrade to a recent version of httpd. Preferably 2.2.x.

*** This bug has been marked as a duplicate of bug 37770 ***