Bug 45758 - Can't compile apache httpd 2.2.9 with mod_ssl
Summary: Can't compile apache httpd 2.2.9 with mod_ssl
Status: RESOLVED DUPLICATE of bug 44384
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.2.9
Hardware: Macintosh other
: P1 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-07 19:45 UTC by dgandra
Modified: 2008-09-24 01:32 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dgandra 2008-09-07 19:45:06 UTC
Can't compile httpd 2.2.9 on Mac OS X 10.5.4 with OpenSSL 0.9.8h installed. 

   The configure command is the following:

CC="darwin-i386-cc" LDFLAGS="-Llibdir"
./configure \
--enable-layout=Darwin \
--enable-mods-shared='all ssl dav cache proxy logio deflate cgi cgid suexec rewrite spelling expires' \
--with-ssl=/usr \
--with-included-apr \
--with-mpm=prefork


   The last make output lines are the following:

include -I/sources/httpd-2.2.9/srclib/apr-util/include -I/sources/httpd-2.2.9/server -I/sources/httpd-2.2.9/modules/proxy/../generators -I/usr/include -I/sources/httpd-2.2.9/modules/ssl -I/sources/httpd-2.2.9/modules/dav/main  -prefer-non-pic -static -c ab.c && touch ab.lo
/sources/httpd-2.2.9/srclib/apr/libtool --silent --mode=link gcc -g -O2     -L/usr/lib   -o ab  ab.lo    /sources/httpd-2.2.9/srclib/pcre/libpcre.la /sources/httpd-2.2.9/srclib/apr-util/libaprutil-1.la -lexpat -liconv /sources/httpd-2.2.9/srclib/apr/libapr-1.la -lpthread -lssl -lcrypto
Undefined symbols:
  "_BIO_set_callback_arg", referenced from:
      _start_connect in ab.o
  "_BIO_get_callback_arg", referenced from:
      _ssl_print_cb in ab.o
  "_SSL_CTX_set_info_callback", referenced from:
      _main in ab.o
  "_BIO_set_callback", referenced from:
      _start_connect in ab.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [ab] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
Comment 1 Joe Orton 2008-09-24 01:32:06 UTC

*** This bug has been marked as a duplicate of bug 44384 ***