Bug 45852 - conf/tomcat-users.xml has invalid encoding "cp932".
conf/tomcat-users.xml has invalid encoding "cp932".
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
6.0.18
PC Windows Vista
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
: 47005 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-09-20 00:17 UTC by Yousei Itou
Modified: 2011-02-02 12:59 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousei Itou 2008-09-20 00:17:35 UTC
Tomcat failed to startup because of it.
Comment 1 Mark Thomas 2008-09-22 14:49:15 UTC
This looks like a regression of bug 45532.

A look at http://java.sun.com/javase/6/docs/technotes/guides/intl/encoding.doc.html shows that using MS932 (or maybe cp942) should work in this case.

Could you test this and if MS932 works then I'll add a special case to the windows installer to replace cp932 with MS932.
Comment 2 Yousei Itou 2008-09-22 18:21:08 UTC
I'd replaced cp932 with utf-8, and it works.
I also tried to reinstall tomcat and replace cp932 with ms932, it works too.

Thank you for reply.
Comment 3 Mark Thomas 2008-09-24 09:03:09 UTC
Thanks for the testing. I have fixed this in trunk and proposed it for 6.0.x.
Comment 4 Yousei Itou 2008-09-24 17:13:22 UTC
Thank you for reply.
Comment 5 Mark Thomas 2008-09-26 03:39:55 UTC
The fix has been applied to 6.0.x and will be in 6.0.19 onwards.
Comment 6 Mark Thomas 2009-04-09 01:54:06 UTC
*** Bug 47005 has been marked as a duplicate of this bug. ***
Comment 7 Konstantin Kolinko 2011-02-02 12:59:27 UTC
The fix was backported to 5.5.x in r1066549 and will be in 5.5.33.