Bug 45937 - Function ':not' not found
Summary: Function ':not' not found
Status: RESOLVED DUPLICATE of bug 45511
Alias: None
Product: Tomcat 6
Classification: Unclassified
Component: Servlet & JSP API (show other bugs)
Version: 6.0.18
Hardware: PC Windows XP
: P2 regression (vote)
Target Milestone: default
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-02 08:22 UTC by Duong
Modified: 2008-10-03 05:54 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Duong 2008-10-02 08:22:59 UTC
The following sample code works in 6.0.16 but not 6.0.18.

<c:set var="a" value="false"/>
<c:set var="b" value="false"/>
<c:set var="c" value="false"/>

<c:out value="${not((not a) && (not b) && (not c))}"/>

Using a bang for the first not works.

<c:out value="${!((not a) && (not b) && (not c))}"/>

From looking at the JSP spec, the "not" and "!" are interchangeable.
Comment 1 Mark Thomas 2008-10-03 05:54:34 UTC
Sorry - my bad. It will be fixed in 6.0.19

*** This bug has been marked as a duplicate of bug 45511 ***