Bug 45999 - Tomcat 5.5.17 won't start service with Java 1.6_5+ installed
Tomcat 5.5.17 won't start service with Java 1.6_5+ installed
Status: RESOLVED DUPLICATE of bug 41538
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
PC Windows Server 2003
: P2 major (vote)
: ---
Assigned To: Tomcat Developers Mailing List
Depends on:
  Show dependency tree
Reported: 2008-10-13 15:33 UTC by Jeff
Modified: 2008-10-14 09:55 UTC (History)
0 users

tomcat log snapshot (102.51 KB, image/jpeg)
2008-10-13 15:34 UTC, Jeff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2008-10-13 15:33:38 UTC
I install JDK 1.6_5 or 1.6_7 and neither will work right after installation.  If i install JDK 1.5_14 it works fine.  What do I need to adjust to get it to work?  I am using Tomcat 5.5.17.  All I want is the service to start.

Comment 1 Jeff 2008-10-13 15:34:26 UTC
Created attachment 22721 [details]
tomcat log snapshot
Comment 2 Preston L. Bannister 2008-10-14 03:27:48 UTC
Looks like this is a duplicate of Bug 41538. 

Upshot is Sun added a JVM dependency on msvcr71.dll, which is NOT guaranteed to be in the PATH. Sun has a bug listed as "Closed, not a defect" for this general issue (which is wrong in my opinion.)


Comment 3 Mark Thomas 2008-10-14 09:55:52 UTC

*** This bug has been marked as a duplicate of bug 41538 ***