Bug 46014 - OCSP Content-Type header missing
Summary: OCSP Content-Type header missing
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.5-HEAD
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk, PatchAvailable
: 48770 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-15 04:55 UTC by Dr Stephen Henson
Modified: 2010-02-19 08:27 UTC (History)
1 user (show)



Attachments
Add missing OCSP Content-Type header. (311 bytes, patch)
2008-10-15 04:55 UTC, Dr Stephen Henson
Details | Diff
Corrected patch this time.... ;-) (583 bytes, patch)
2008-10-15 04:57 UTC, Dr Stephen Henson
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dr Stephen Henson 2008-10-15 04:55:42 UTC
Created attachment 22735 [details]
Add missing OCSP Content-Type header.

The Content-Type header is missing in the OCSP request code. This causes some responders to reject the requests. This requirement is detailed in RFC2560 A.1.1 .
Comment 1 Dr Stephen Henson 2008-10-15 04:57:49 UTC
Created attachment 22736 [details]
Corrected patch this time.... ;-)
Comment 2 Ruediger Pluem 2008-10-15 06:42:06 UTC
Thanks for the patch. Committed to trunk as r704917 (http://svn.apache.org/viewvc?rev=704917&view=rev).
Comment 3 Joe Orton 2010-02-19 08:27:15 UTC
*** Bug 48770 has been marked as a duplicate of this bug. ***