Bug 46025 - --enable-shared is not available in apache's configure file and don't work
Summary: --enable-shared is not available in apache's configure file and don't work
Status: RESOLVED DUPLICATE of bug 46024
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.2.10
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-16 07:00 UTC by Yannick LE NY
Modified: 2008-10-16 07:19 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yannick LE NY 2008-10-16 07:00:29 UTC
I found nothing about this problem in Apache bugzilla.

When I do :
./configure --help
i can not see the option :
--enable-shared

I found nothing about that this option was removed in
http://www.apache.org/dist/httpd/CHANGES_2.0
or
http://www.apache.org/dist/httpd/CHANGES_2.2

Please can you add --enable-shared as option
in configure file when I do ./configure --help or
if this option is not available now, please add this change
in the apache 2.2.x changes or changelog file and explain why this option is removed.

Use ./buildconf in httpd-2.2.10 folder and next do configure don't help  

When I do ./configure , i have this error message :
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... config.sub: missing argument
Try `config.sub --help' for more information.
configure: error: /bin/sh build/config.sub   failed
./script.03_apache_httpd.linux32: line 65: --enable-shared: command not found
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.


Environment :
Apache 2.2.10
Redhat Linux ES4.0
GNU Make 3.80
autoconf (GNU Autoconf) 2.59
automake (GNU automake) 1.9.2
Comment 1 Ruediger Pluem 2008-10-16 07:19:21 UTC

*** This bug has been marked as a duplicate of bug 46024 ***