Bug 46279 - Non-Gui Mode with Java 1.5.0_16 Not Working
Summary: Non-Gui Mode with Java 1.5.0_16 Not Working
Status: RESOLVED INVALID
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.3.2
Hardware: All Linux
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-24 09:50 UTC by Bardia
Modified: 2008-11-24 11:07 UTC (History)
1 user (show)



Attachments
JMeter Log file with errors (8.30 KB, application/octet-stream)
2008-11-24 10:56 UTC, Bardia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bardia 2008-11-24 09:50:22 UTC
When I try to launch JMeter in a Linux environment (NON-GUI) with the following command:  

jmeter -n -t MyTestFile.jmx I get the following exception on the console:

java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.apache.jmeter.NewDriver.main(NewDriver.java:184)
Caused by: java.lang.NoSuchMethodError: org.apache.jmeter.util.JMeterUtils.getImage(Ljava/lang/String;Ljava/lang/String;)Ljavax/swing/ImageIcon;
	at org.apache.jmeter.visualizers.TableVisualizer.<clinit>(TableVisualizer.java:62)


Here is the log:

2008/11/24 09:44:31 WARN  - jmeter.util.JMeterUtils: ERROR! Resource string not found: [realm] java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key realm
        at java.util.ResourceBundle.getObject(ResourceBundle.java:386)
        at java.util.ResourceBundle.getString(ResourceBundle.java:346)
        at org.apache.jmeter.util.JMeterUtils.getResStringDefault(JMeterUtils.java:342)
        at org.apache.jmeter.util.JMeterUtils.getResString(JMeterUtils.java:306)
        at org.apache.jmeter.protocol.http.control.AuthManager.<clinit>(AuthManager.java:58)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at org.apache.jmeter.save.SaveService.makeAlias(SaveService.java:127)
        at org.apache.jmeter.save.SaveService.initProps(SaveService.java:158)
        at org.apache.jmeter.save.SaveService.<clinit>(SaveService.java:120)
        at org.apache.jmeter.JMeter.run(JMeter.java:572)
        at org.apache.jmeter.JMeter.startNonGui(JMeter.java:552)
        at org.apache.jmeter.JMeter.start(JMeter.java:291)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.jmeter.NewDriver.main(NewDriver.java:210)

2008/11/24 09:44:31 INFO  - jmeter.samplers.SampleResult: Note: Sample TimeStamps are START times
2008/11/24 09:44:31 INFO  - jmeter.samplers.SampleResult: sampleresult.default.encoding is set to ISO-8859-1
2008/11/24 09:44:31 INFO  - jmeter.save.SaveService: Using SaveService properties file version 661482
2008/11/24 09:44:31 WARN  - jmeter.save.SaveService: Could not set up alias MailerModel java.lang.NoClassDefFoundError: javax/mail/Message
2008/11/24 09:44:31 INFO  - jmeter.save.SaveService: Using SaveService properties file version 661482
2008/11/24 09:44:31 WARN  - jmeter.save.SaveService: Could not set up alias MailerModel java.lang.NoClassDefFoundError: javax/mail/Message
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSamplerBase: Cannot find .className property for htmlParser, using default
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSamplerBase: Parser for text/html is
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSamplerBase: Parser for application/xhtml+xml is
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSamplerBase: Parser for application/xml is
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSamplerBase: Parser for text/xml is
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSamplerBase: Parser for text/vnd.wap.wml is org.apache.jmeter.protocol.http.parser.RegexpHTMLParser  
2008/11/24 09:44:31 INFO  - jmeter.protocol.http.sampler.HTTPSampler2: Local host = dc1-fnd-dev02
2008/11/24 09:44:31 WARN  - jmeter.save.SaveService: Can't register a converter: org.apache.jmeter.protocol.http.util.HTTPResultConverter java.lang.NoSuchMethodException: org.apache.jmeter.protocol.http.util.HTTPResultConverter.<init>(com.thoughtworks.xstream.alias.ClassMapper)
        at java.lang.Class.getConstructor0(Class.java:2706)
        at java.lang.Class.getConstructor(Class.java:1657)
        at org.apache.jmeter.save.SaveService.initProps(SaveService.java:171)
        at org.apache.jmeter.save.SaveService.<clinit>(SaveService.java:120)
        at org.apache.jmeter.JMeter.run(JMeter.java:572)
        at org.apache.jmeter.JMeter.startNonGui(JMeter.java:552)
        at org.apache.jmeter.JMeter.start(JMeter.java:291)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.jmeter.NewDriver.main(NewDriver.java:210)
        
2008/11/24 09:44:31 WARN  - jmeter.save.SaveService: Could not set up alias HttpGenericSamplerGui java.lang.ClassNotFoundException: org.apache.jmeter.protocol.http.control.gui.HttpGenericSamplerGui
2008/11/24 09:44:32 INFO  - jmeter.protocol.http.sampler.HTTPSampler: Maximum connection retries = 10
2008/11/24 09:44:32 WARN  - jmeter.save.SaveService: Could not set up alias JMSSampler java.lang.NoClassDefFoundError: javax/jms/Message
2008/11/24 09:44:32 WARN  - jmeter.save.SaveService: Could not set up alias SubscriberSampler java.lang.NoClassDefFoundError: javax/jms/MessageListener
Comment 1 Sebb 2008-11-24 10:52:13 UTC
It looks like your JMeter installation is incomplete.

Please post the full jmeter.log file
Comment 2 Bardia 2008-11-24 10:56:25 UTC
Created attachment 22927 [details]
JMeter Log file with errors
Comment 3 Bardia 2008-11-24 10:58:17 UTC
Added attachment (jmeter.log)

Thanks,

Bardia
Comment 4 Bardia 2008-11-24 11:05:08 UTC
We can close this issue, I figured out one of my jars in lib/ext was packaging javax.mail classes without packing transitive dependencies.

Thanks,

Bardia
Comment 5 Sebb 2008-11-24 11:07:19 UTC
Furthermore, the JMeter installation is broken.

JMeter is reporting:
Version 2.2

Yet it is installed in directory 2.3.2, and the bug is reported against 2.3.2.
JMeterHome=/home/bdejban/coast-mule-test/jakarta-jmeter-2.3.2

Reinstall JMeter.