Bug 46345 - Problems with Excel Function "VERKETTEN"
Summary: Problems with Excel Function "VERKETTEN"
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.2-dev
Hardware: Sun SunOS
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-05 00:25 UTC by Joerg Bruennert
Modified: 2015-05-02 06:26 UTC (History)
0 users



Attachments
Template and Result XLS File (7.64 KB, application/x-zip-compressed)
2008-12-05 00:25 UTC, Joerg Bruennert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Bruennert 2008-12-05 00:25:21 UTC
Created attachment 22995 [details]
Template and Result XLS File

I have Problems with Excel Function "VERKETTEN" since i use Office 2007.
With Office 2000 i don't have this bug.

I use POI with a Excel Template File (template.xls)
On one sheet (Tabelle1) in cell (A4) i use the Excel Function VERKETTEN

=VERKETTEN("TEST ";Tabelle2!A2; " VOLLENDET")

Then POI fill a value (25) in cell A2 on Tabelle 2 and write it
to result.xls

The Problem is that this value is not shown in the VERKETTEN cell ...
Only "TEST VOLLENDET"

After i doubleklick in cell A4 on Tabelle1 then press enter the correct
value is shown "TEST 25 VOLLENDET".
Comment 1 Dominik Stadler 2015-05-02 06:26:30 UTC
I expect that you did not evaluate the cells before writing the document out, see http://poi.apache.org/spreadsheet/eval.html for details. 

If this still does not work then please reopen this bug and post the actual code that you are using, preferably as self-sufficient unit-test so we can reproduce the problem.