Bug 46597 - Not all cookie changes in 6.0.x branch have been ported to 5.5.x
Not all cookie changes in 6.0.x branch have been ported to 5.5.x
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
Nightly Build
All All
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 44705 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-01-25 01:34 UTC by Mark Thomas
Modified: 2009-04-29 09:38 UTC (History)
2 users (show)



Attachments
Proposed port of new cookie functionality (16.74 KB, text/plain)
2009-03-27 07:42 UTC, Mark Thomas
Details
New patch without httpOnly support (10.10 KB, text/plain)
2009-04-16 03:24 UTC, Mark Thomas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Thomas 2009-01-25 01:34:57 UTC
Need to check the STATUS file and generate a proposal for the cookie patches applied to 6.0.x that have not yet been proposed for 5.5.x
Comment 1 Mark Thomas 2009-03-27 07:42:04 UTC
Created attachment 23421 [details]
Proposed port of new cookie functionality

I have attached a patch the ports the current ServerCookie implementation from 6.0.x along with support for httpOnly.
Comment 2 Mark Thomas 2009-03-27 07:46:15 UTC
*** Bug 44705 has been marked as a duplicate of this bug. ***
Comment 3 Mark Thomas 2009-04-09 04:11:06 UTC
The patch has been proposed for 5.5.x
Comment 4 David Lewis 2009-04-09 09:55:15 UTC
I look forward to this patch being integrated into the next Tomcat 5.5.x. Until our organization migrates to Java 6/Tomcat 6, we are "stuck" using Tomcat 5.5.25 due to cookie compatibility issues.
Comment 5 jfclere 2009-04-16 02:40:48 UTC
I think the HttpOnly in the patch is a new feature it should go in another error report.
Comment 6 Mark Thomas 2009-04-16 03:24:24 UTC
Created attachment 23498 [details]
New patch without httpOnly support

As requested, a new patch minus httponly support is attached
Comment 7 Mark Thomas 2009-04-29 02:38:43 UTC
This patch has been applied to 5.5.x and will be in 5.5.28 onwards.
Comment 8 David Lewis 2009-04-29 09:38:37 UTC
Thanks! Is there an ETA for the 5.5.28 release?