Bug 46735 - Error for struts tags for new version of tomcat
Summary: Error for struts tags for new version of tomcat
Status: RESOLVED INVALID
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Application Taglib (show other bugs)
Version: unspecified
Hardware: PC Windows Server 2003
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-19 06:33 UTC by Shripad Shingne
Modified: 2009-08-17 01:55 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shripad Shingne 2009-02-19 06:33:19 UTC
Application that is running properly on tomcat 5.0.28 is giving following error on JBoss Web/2.1.2.GA 


type Exception report

message 

description The server encountered an internal error () that prevented it from fulfilling this request.

exception 

org.apache.jasper.JasperException: Failed to load or instantiate TagExtraInfo class: org.apache.struts.taglib.logic.IterateTei
	org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:51)
	org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:409)
	org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:281)
	org.apache.jasper.compiler.TagLibraryInfoImpl.createTagInfo(TagLibraryInfoImpl.java:415)
	org.apache.jasper.compiler.TagLibraryInfoImpl.parseTLD(TagLibraryInfoImpl.java:250)
	org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:163)
	org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:429)
	org.apache.jasper.compiler.Parser.parseDirective(Parser.java:491)
	org.apache.jasper.compiler.Parser.parseElements(Parser.java:1438)
	org.apache.jasper.compiler.Parser.parse(Parser.java:137)
	org.apache.jasper.compiler.ParserController.doParse(ParserController.java:255)
	org.apache.jasper.compiler.ParserController.parse(ParserController.java:103)
	org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:171)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:333)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:313)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:300)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:585)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:312)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:322)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:249)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717)


root cause 

java.lang.ClassCastException: org.apache.struts.taglib.logic.IterateTei
	org.apache.jasper.compiler.TagLibraryInfoImpl.createTagInfo(TagLibraryInfoImpl.java:413)
	org.apache.jasper.compiler.TagLibraryInfoImpl.parseTLD(TagLibraryInfoImpl.java:250)
	org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:163)
	org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:429)
	org.apache.jasper.compiler.Parser.parseDirective(Parser.java:491)
	org.apache.jasper.compiler.Parser.parseElements(Parser.java:1438)
	org.apache.jasper.compiler.Parser.parse(Parser.java:137)
	org.apache.jasper.compiler.ParserController.doParse(ParserController.java:255)
	org.apache.jasper.compiler.ParserController.parse(ParserController.java:103)
	org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:171)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:333)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:313)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:300)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:585)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:312)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:322)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:249)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717)


note The full stack trace of the root cause is available in the JBoss Web/2.1.2.GA logs.
Comment 1 Henri Yandell 2009-02-25 20:37:18 UTC
You should report this to the Struts project:

https://issues.apache.org/struts/secure/Dashboard.jspa

Apologies for the multiple trackers, we're on the old one.
Comment 2 Mark Thomas 2009-08-17 01:55:53 UTC
Update assignee to Tomcat dev list