Bug 46906 - Improve Exception Handling When Encountering OOXML using POIFS
Summary: Improve Exception Handling When Encountering OOXML using POIFS
Status: RESOLVED LATER
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: 3.2-FINAL
Hardware: PC Mac OS X 10.4
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-24 09:13 UTC by David Fisher
Modified: 2010-06-04 10:48 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Fisher 2009-03-24 09:13:06 UTC
Error messages like the following say that POI does not support OOXML.

org.apache.poi.poifs.filesystem.OfficeXmlFileException: The supplied data
appears to be in the Office 2007+ XML. POI only supports OLE2 Office
documents

Now that we have support for OOXML the error message generated ought to provide some more help in getting to the proper support in POI. Ideally we would determine which OOXML and point the user to our current support. Maybe the best thing would be to point to a URL on the site for a guide.
Comment 1 Nick Burch 2009-03-24 09:15:43 UTC
The error message in POIFS for poi 3.5 is different and more helpful

The issue is that poi 3.2 (which the error quoted comes from) didn't support ooxml. I guess we could do a new poi 3.2.1 release with a new error message telling you to upgrade, if there's any demand?
Comment 2 David Fisher 2009-03-24 09:20:14 UTC
If we plan to keep 3.2 around after 3.5-FINAL then we definitely need a 3.2.1 to clean up some of the minor license issues in the scratchpad.

I've changed this to 3.2-FINAL issue.
Comment 3 Nick Burch 2010-06-04 10:48:39 UTC
I think we can close this, as 3.2.1 never happened, and 3.5 had the correct message