Bug 46910 - properties files in tomcat-i18n-fr.jar misencoded
properties files in tomcat-i18n-fr.jar misencoded
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
6.0.18
PC Windows 2000
: P2 minor (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
: 47049 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-03-25 05:58 UTC by ludovic.walle
Modified: 2009-05-26 16:44 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ludovic.walle 2009-03-25 05:58:09 UTC
Characters such as éàè have been replaced by U+FFFD REPLACEMENT CHARACTER in french properties files in tomcat-i18n-fr.jar.

So, messages in catalina.out looks like
GRAVE: "Servlet.service()" pour la servlet Slave000 a g�n�r� une exception
instead of
GRAVE: "Servlet.service()" pour la servlet Slave000 a généré une exception
Comment 1 Mark Thomas 2009-03-25 09:00:54 UTC
I observe the same issue with 6.0.18 and the 6.0.19 release candidate but I can't reproduce this on my  machine. It looks like an issue with the RM's build environment. Investigations continue.
Comment 2 Mark Thomas 2009-04-07 12:47:17 UTC
Root cause found and fixed in 6.0.x and trunk. It will be used from 6.0.20 onwards.
Comment 3 Konstantin Kolinko 2009-05-26 16:44:38 UTC
*** Bug 47049 has been marked as a duplicate of this bug. ***