Bug 46930 - Provide support for renaming JSESSIONID per webapp
Provide support for renaming JSESSIONID per webapp
Status: RESOLVED DUPLICATE of bug 48379
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
6.0.18
PC Linux
: P2 enhancement (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-03-27 12:25 UTC by Bart Hazer
Modified: 2010-07-23 08:12 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bart Hazer 2009-03-27 12:25:23 UTC
The fixes implemented for bug 45951 and bug 42419 are a huge step forward for configuring the session cookie name.  However, a situation could exist similar to what is described in bug 42419, but instead of the applications being deployed to different servers they are separate webapps deployed on the same server.  In that case, is there a way to vary the session cookie name by webapp?
Comment 1 Mark Thomas 2009-03-27 15:40:13 UTC
It is possible but you'd have to switch configuration to the Context. When that was raised previously, the general feeling was that that level of control would not be required.

The patch should be pretty simple.
Comment 2 Mark Thomas 2010-07-23 08:12:57 UTC

*** This bug has been marked as a duplicate of bug 48379 ***