Bug 47005 - Does not render pages on native Japanese windows server 2003
Summary: Does not render pages on native Japanese windows server 2003
Status: RESOLVED DUPLICATE of bug 45852
Alias: None
Product: Tomcat 6
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 6.0.18
Hardware: PC Windows Server 2003
: P1 blocker (vote)
Target Milestone: default
Assignee: Tomcat Developers Mailing List
URL: http://java-monitor.com/forum/showthr...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-08 22:40 UTC by bsgcic1776
Modified: 2009-04-09 01:54 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bsgcic1776 2009-04-08 22:40:17 UTC
Installed on windows 2003 server enterprise SP2 Japanese OS (i.e., OS is the native Japanese version).
Installs fine. However, pages not rendered even for http://localhost:8080 and just timeout.
Looks like someone else also had this issue on a non-native Japanese system when configured with Japanese code pages. See url for those details.
Comment 1 bsgcic1776 2009-04-08 22:52:01 UTC
Some of the log file contents:

Translations of Japanese error messages added in brackets following the Japanese text:


2009/04/09 14:03:10 org.apache.catalina.core.AprLifecycleListener init
情報[info]: Loaded APR based Apache Tomcat Native library 1.1.14.
2009/04/09 14:03:10 org.apache.catalina.core.AprLifecycleListener init
情報: APR capabilities: IPv6 [false], sendfile [true], accept filters [false], random [true].
2009/04/09 14:03:11 org.apache.coyote.http11.Http11AprProtocol init
情報: Coyote HTTP/1.1を http-8080 で初期化します[Start Coyote ... on http-8080]
2009/04/09 14:03:11 org.apache.coyote.ajp.AjpAprProtocol init
情報: Initializing Coyote AJP/1.3 on ajp-8009
2009/04/09 14:03:11 org.apache.catalina.startup.Catalina load
情報: Initialization processed in 841 ms
2009/04/09 14:03:11 org.apache.naming.NamingContext lookup
警告: 参照の解決中に予測しない例外が発生しました[Warning: Unexpected exception occurred while resolving reference]
java.io.UnsupportedEncodingException: cp932
	at sun.nio.cs.StreamDecoder.forInputStreamReader(Unknown Source)
	at java.io.InputStreamReader.<init>(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.createReader(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.setEncoding(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanXMLDeclOrTextDecl(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$XMLDeclDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1663)
	at org.apache.catalina.users.MemoryUserDatabase.open(MemoryUserDatabase.java:402)
	at org.apache.catalina.users.MemoryUserDatabaseFactory.getObjectInstance(MemoryUserDatabaseFactory.java:103)
	at org.apache.naming.factory.ResourceFactory.getObjectInstance(ResourceFactory.java:140)
	at javax.naming.spi.NamingManager.getObjectInstance(Unknown Source)
	at org.apache.naming.NamingContext.lookup(NamingContext.java:793)
	at org.apache.naming.NamingContext.lookup(NamingContext.java:140)
	at org.apache.naming.NamingContextBindingsEnumeration.nextElementInternal(NamingContextBindingsEnumeration.java:113)
	at org.apache.naming.NamingContextBindingsEnumeration.next(NamingContextBindingsEnumeration.java:71)
	at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:137)
	at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:109)
	at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.lifecycleEvent(GlobalResourcesLifecycleListener.java:81)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:703)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
2009/04/09 14:03:11 org.apache.catalina.mbeans.GlobalResourcesLifecycleListener createMBeans
致命的: Exception processing Global JNDI Resources
javax.naming.NamingException: cp932
	at org.apache.naming.NamingContext.lookup(NamingContext.java:805)
	at org.apache.naming.NamingContext.lookup(NamingContext.java:140)
	at org.apache.naming.NamingContextBindingsEnumeration.nextElementInternal(NamingContextBindingsEnumeration.java:113)
	at org.apache.naming.NamingContextBindingsEnumeration.next(NamingContextBindingsEnumeration.java:71)
	at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:137)
	at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.createMBeans(GlobalResourcesLifecycleListener.java:109)
	at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.lifecycleEvent(GlobalResourcesLifecycleListener.java:81)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:703)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
2009/04/09 14:03:11 org.apache.catalina.core.StandardService start
情報: サービス Catalina を起動します[Catalina started]
2009/04/09 14:03:11 org.apache.catalina.core.StandardEngine start
情報: Starting Servlet Engine: Apache Tomcat/6.0.18
2009/04/09 14:03:11 org.apache.naming.NamingContext lookup
警告: 参照の解決中に予測しない例外が発生しました[Warning: Unexpected exception occurred while resolving reference]
java.io.UnsupportedEncodingException: cp932
	at sun.nio.cs.StreamDecoder.forInputStreamReader(Unknown Source)
	at java.io.InputStreamReader.<init>(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.createReader(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.setEncoding(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanXMLDeclOrTextDecl(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$XMLDeclDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1663)
	at org.apache.catalina.users.MemoryUserDatabase.open(MemoryUserDatabase.java:402)
	at org.apache.catalina.users.MemoryUserDatabaseFactory.getObjectInstance(MemoryUserDatabaseFactory.java:103)
	at org.apache.naming.factory.ResourceFactory.getObjectInstance(ResourceFactory.java:140)
	at javax.naming.spi.NamingManager.getObjectInstance(Unknown Source)
	at org.apache.naming.NamingContext.lookup(NamingContext.java:793)
	at org.apache.naming.NamingContext.lookup(NamingContext.java:153)
	at org.apache.catalina.realm.UserDatabaseRealm.start(UserDatabaseRealm.java:253)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1037)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
2009/04/09 14:03:11 org.apache.catalina.realm.UserDatabaseRealm start
致命的: キー UserDatabase でユーザデータベースを検索中の例外です[Exception while searching user database via UserDatabase key]
javax.naming.NamingException: cp932
	at org.apache.naming.NamingContext.lookup(NamingContext.java:805)
	at org.apache.naming.NamingContext.lookup(NamingContext.java:153)
	at org.apache.catalina.realm.UserDatabaseRealm.start(UserDatabaseRealm.java:253)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1037)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
2009/04/09 14:03:11 org.apache.catalina.startup.Catalina start
致命的: Catalina.start: 
LifecycleException:  キー UserDatabase でユーザデータベースコンポーネントが見つかりません[Could not find user database component via UserDatabase key]
	at org.apache.catalina.realm.UserDatabaseRealm.start(UserDatabaseRealm.java:261)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1037)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
2009/04/09 14:03:11 org.apache.catalina.startup.Catalina start
情報[info]: Server startup in 65 ms
Comment 2 Mark Thomas 2009-04-09 01:54:06 UTC

*** This bug has been marked as a duplicate of bug 45852 ***