Bug 47032 - /status/all fails if using PersistentManager
/status/all fails if using PersistentManager
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Manager
5.5.23
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-04-14 12:13 UTC by olivier dupuy
Modified: 2009-05-25 03:00 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olivier dupuy 2009-04-14 12:13:09 UTC
Hello,

This bug is in Tomcat 5.5.23. 
We got it once we modified a context.xml of our application to disable session persistence.
In META-INF/context.xml for our application we have added and tested as OK
	<!-- Turn off session serialization -->
    <Manager className="org.apache.catalina.session.PersistentManager"
      debug="0" distributable="false" saveOnRestart="false" sessionMaxAliveTime="">
        <Store className="org.apache.catalina.session.FileStore"/>
    </Manager>

But as a consequence, in the application manager, when I click on the "complete server status" link I get the error below.
I have been unable to test the problem with the latest 5.5 release.
This bug seems related 46816 raised and fixed for Tomcat 6.
https://issues.apache.org/bugzilla/show_bug.cgi?id=46816
I want to have access to the full status to get some details about the created sessions and the usage of my application.

Thanks
Olivier

HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException:  Cannot find attribute sessionMaxAliveTime
	org.apache.catalina.manager.StatusManagerServlet.doGet(StatusManagerServlet.java:306)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

root cause
javax.management.AttributeNotFoundException:  Cannot find attribute sessionMaxAliveTime
	org.apache.commons.modeler.BaseModelMBean.getAttribute(BaseModelMBean.java:259)
	com.sun.jmx.mbeanserver.DynamicMetaDataImpl.getAttribute(Unknown Source)
	com.sun.jmx.mbeanserver.MetaDataImpl.getAttribute(Unknown Source)
	com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(Unknown Source)
	com.sun.jmx.mbeanserver.JmxMBeanServer.getAttribute(Unknown Source)
	org.apache.catalina.manager.StatusTransformer.writeManager(StatusTransformer.java:723)
	org.apache.catalina.manager.StatusTransformer.writeContext(StatusTransformer.java:675)
	org.apache.catalina.manager.StatusTransformer.writeDetailedState(StatusTransformer.java:600)
	org.apache.catalina.manager.StatusManagerServlet.doGet(StatusManagerServlet.java:301)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
note The full stack trace of the root cause is available in the Apache Tomcat/5.5.23 logs.
Comment 1 Mark Thomas 2009-04-16 13:09:00 UTC
I have proposed the same fix for 5.5.x
Comment 2 Mark Thomas 2009-05-25 03:00:51 UTC
This has been fixed in 5.5.x and will be included in 5.5.28 onwards.