Bug 47235 - MySQL example should *not* include usage of the autoReconnect flag
MySQL example should *not* include usage of the autoReconnect flag
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Documentation
unspecified
PC Windows XP
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
http://tomcat.apache.org/tomcat-6.0-d...
:
: 48080 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-05-21 07:47 UTC by Eric DeCosta
Modified: 2009-11-03 16:27 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric DeCosta 2009-05-21 07:47:38 UTC
See: http://dev.mysql.com/doc/refman/5.1/en/connector-j-reference-configuration-properties.html

"...The use of this feature is not recommended, because it has side effects related to session state and data consistency when applications do not handle SQLExceptions properly, and is only designed to be used when you are unable to configure your application to handle SQLExceptions resulting from dead and stale connections properly..."
Comment 1 Mark Thomas 2009-05-25 03:18:44 UTC
Thanks for the report. This has been fixed in trunk, 6.0.x, 5.5.x and 4.1.x and will be included in 6.0.21, 5.5.28 and 4.1.40 respectively.
Comment 2 Mark Thomas 2009-11-03 16:27:46 UTC
*** Bug 48080 has been marked as a duplicate of this bug. ***