Bug 47288 - JMS samples use write id for correlation
Summary: JMS samples use write id for correlation
Status: RESOLVED DUPLICATE of bug 46142
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: Nightly (Please specify date)
Hardware: PC Windows Vista
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-30 14:17 UTC by Peter Johnson
Modified: 2009-07-23 20:59 UTC (History)
0 users



Attachments
Patch for protocol.jms.sampler.Receiver (825 bytes, patch)
2009-05-30 14:17 UTC, Peter Johnson
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Johnson 2009-05-30 14:17:38 UTC
Created attachment 23731 [details]
Patch for protocol.jms.sampler.Receiver

Patch r701218, which introduces useReqMsgIdAsCorrelId does not go far enough. In ...protocol.jms.sampler.Receiver.run(), the JMSMessageId is passed to MessageAdmin. But this is the unique message id for the response message and those correlation between the response and the original request fails. Instead, the JMSCorrelationId should be passed to MessageAdmin.

A patch is attached.
Comment 1 rohan.hart17 2009-07-23 20:59:46 UTC
This was caused by 46142.  I've asked for that to be backed out.

*** This bug has been marked as a duplicate of bug 46142 ***