Bug 47352 - cloneSheet does not copy chart
Summary: cloneSheet does not copy chart
Status: RESOLVED DUPLICATE of bug 54470
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.5-dev
Hardware: PC Windows XP
: P2 normal with 1 vote (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-11 02:36 UTC by Bart De Tandt
Modified: 2015-03-18 20:20 UTC (History)
0 users



Attachments
Excel file for test (9.57 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2009-06-11 02:37 UTC, Bart De Tandt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bart De Tandt 2009-06-11 02:36:37 UTC
When invoking the following code:

	public static void main(String[] args) {

		try {
			System.out.println("opening xslx workbook !");
			XSSFWorkbook wb = new XSSFWorkbook("d:/test.xlsx");
			XSSFSheet sheet = wb.getSheetAt(0);
		    
		    wb.cloneSheet(0);
		    
 
		    
		    // Write the output to a file
		    FileOutputStream fileOut = new FileOutputStream("d:/workbook.xlsx");
		    wb.write(fileOut);
		    fileOut.close();

		} catch (FileNotFoundException e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		} catch (IOException e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		}

	}


based on the test.xlsx in attachment, the sheet is cloned but the chart is not copied to the destinated sheet.
Comment 1 Bart De Tandt 2009-06-11 02:37:05 UTC
Created attachment 23791 [details]
Excel file for test
Comment 2 Dominik Stadler 2015-03-18 20:20:36 UTC
There is a patch proposed in bug 54470 which should allow this, therefore I am marking this bug as duplicate.

*** This bug has been marked as a duplicate of bug 54470 ***