Bug 47487 - "null " as result of expression evaluation
Summary: "null " as result of expression evaluation
Status: RESOLVED DUPLICATE of bug 47413
Alias: None
Product: Tomcat 6
Classification: Unclassified
Component: Servlet & JSP API (show other bugs)
Version: 6.0.20
Hardware: PC Windows Vista
: P2 critical (vote)
Target Milestone: default
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-07 03:44 UTC by Alfred Staflinger
Modified: 2009-07-18 20:08 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alfred Staflinger 2009-07-07 03:44:56 UTC
When i have a JSP page with this tag/expression...

<c:out value="${assignment.companyHeader.address.name01} ${assignment.companyHeader.address.name02}" />

... and "companyHeader" evaluates to null, 

the output in Tomcat 6.0.18 is " " (which is correct),

but the output in Tomcat 6.0.20 is "null " (which is not correct).
Comment 1 Konstantin Kolinko 2009-07-18 20:08:38 UTC

*** This bug has been marked as a duplicate of bug 47413 ***