Bug 47495 - provide meaningful error message also to stdout if server.xml is not readable
provide meaningful error message also to stdout if server.xml is not readable
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
unspecified
PC Linux
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-07-08 02:20 UTC by Ralf Hauser
Modified: 2009-12-16 08:50 UTC (History)
0 users



Attachments
tc_bug_47495_patch.txt (1.49 KB, text/plain)
2009-07-08 02:30 UTC, Ralf Hauser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Hauser 2009-07-08 02:20:47 UTC
<<java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
Caused by: java.lang.NullPointerException
	at org.apache.catalina.startup.Catalina.await(Catalina.java:647)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:576)
	... 6 more>>
is not a particularly meaningful way to tell the user that tomcat cannot read the server.xml

another issue with insufficient reporting on server.xml user-editing-mishaps is bug 44017
Comment 1 Ralf Hauser 2009-07-08 02:30:33 UTC
Created attachment 23940 [details]
tc_bug_47495_patch.txt

some basic ideas to make the problem easier solvable
Comment 2 Tim Funk 2009-11-05 10:47:34 UTC
made a more explicit check instead 

change applied in trunk with 833121
Comment 3 Mark Thomas 2009-11-18 05:20:12 UTC
Tim's patch has been applied to 6.0.x and will be in 6.0.21 onwards.

Konstantin has also proposed an additional patch.
Comment 4 Mark Thomas 2009-12-16 08:50:58 UTC
Konstantin's additional patch has also been applied to 6.0.x and will be included in 6.0.21 onwards.