Bug 47822 - org.apache.jasper.JasperException: jsp:getProperty for bean with name 'data'. Name was not previously introduced as per JSP.5.3
Summary: org.apache.jasper.JasperException: jsp:getProperty for bean with name 'data'....
Status: RESOLVED DUPLICATE of bug 48701
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 5.5.28
Hardware: All Windows XP
: P2 blocker (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-11 05:01 UTC by Bala
Modified: 2010-03-09 14:30 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bala 2009-09-11 05:01:09 UTC
Hi,

I am facing an issue with Tomcat 5.5.28.

I am using Custom tags in my jsp.

when I run the application, its giving 

"org.apache.jasper.JasperException: jsp:getProperty for bean with name 'data'. Name was not previously introduced as per JSP.5.3".

And my code as below.


<%@page contentType="text/html; charset=UTF-8" import="org.activebpel.rt.util.*"  %>

<%@ taglib uri="http://activebpel.org/aetaglib" prefix="ae" %>

<jsp:useBean id="testListBean" class="org.activebpel.rt.war.AeTestListingBean" />

<table border="0" cellpadding="0" cellspacing="0" width="100%" align="left">
   <ae:IndexedProperty name="testListBean" id="data" property="data" indexedClassName="org.activebpel.rt.war.AeTestDetail" >
      <tr>
         <td align="left"><jsp:getProperty name="data" property="id"/></td>
         <td align="left"><jsp:getProperty name="data" property="value"/></td>
      </tr>
   </ae:IndexedProperty>
</table>


Please let me know the reason why its happening and fix also.

Its very important.
Comment 1 Mark Thomas 2009-09-11 05:22:34 UTC
This is a regression caused by the fix for 38797. The fix should be in the next 5.5.x release.

*** This bug has been marked as a duplicate of bug 38797 ***
Comment 2 Rich Naylor 2009-09-11 06:41:34 UTC
(In reply to comment #0)
> Hi,
> 
> I am facing an issue with Tomcat 5.5.28.
> 
> I am using Custom tags in my jsp.
> 
> when I run the application, its giving 
> 
> "org.apache.jasper.JasperException: jsp:getProperty for bean with name 'data'.
> Name was not previously introduced as per JSP.5.3".
> 
> And my code as below.
> 
> 
> <%@page contentType="text/html; charset=UTF-8"
> import="org.activebpel.rt.util.*"  %>
> 
> <%@ taglib uri="http://activebpel.org/aetaglib" prefix="ae" %>
> 
> <jsp:useBean id="testListBean" class="org.activebpel.rt.war.AeTestListingBean"
> />
> 
> <table border="0" cellpadding="0" cellspacing="0" width="100%" align="left">
>    <ae:IndexedProperty name="testListBean" id="data" property="data"
> indexedClassName="org.activebpel.rt.war.AeTestDetail" >
>       <tr>
>          <td align="left"><jsp:getProperty name="data" property="id"/></td>
>          <td align="left"><jsp:getProperty name="data" property="value"/></td>
>       </tr>
>    </ae:IndexedProperty>
> </table>
> 
> 
> Please let me know the reason why its happening and fix also.
> 
> Its very important.

ActiveVOS was not certified with Tomcat 5.5.28, please use version 5.5.27 and you should not have any issues. If you must use 5.5.28 for any reason, you would need to upgrade to ActiveVOS 7.0 which should be released before end of month. We have created a workaround in the JSP pages to address the issue with Tomcat 5.5.28
Comment 3 Konstantin Kolinko 2010-03-09 14:30:47 UTC

*** This bug has been marked as a duplicate of bug 48701 ***