Bug 47951 - use libtool --mode=install install instead of cp command
Summary: use libtool --mode=install install instead of cp command
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: support (show other bugs)
Version: 2.5-HEAD
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk
: 41989 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-07 01:39 UTC by hirose31
Modified: 2012-02-26 16:59 UTC (History)
1 user (show)



Attachments
patch for build/instdso.sh (445 bytes, application/octet-stream)
2009-10-07 01:39 UTC, hirose31
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hirose31 2009-10-07 01:39:15 UTC
Created attachment 24352 [details]
patch for build/instdso.sh

apix -i do copy mod_foo.so with cp command (libtool --mode=install cp).
copying mod_foo.so with cp command cause httpd process segmentation fault.

Because cp command overwrites existing mod_foo.so file.

On the other hand, install command do unlink(2) mod_foo.so before copy module
file. This is safe. so if user has install command, it is better to use install
command (libtool --mode=install install) instead of cp command.

see also attached patch file.

thanks.
Comment 1 Takashi Sato 2009-10-07 09:20:50 UTC
*** Bug 41989 has been marked as a duplicate of this bug. ***
Comment 2 Takashi Sato 2009-10-09 10:00:34 UTC
Committed in r47951. Thanks for the report and the patch.
Comment 3 Takashi Sato 2009-10-09 10:01:21 UTC
Oops, r823613 is correct.
Comment 4 Stefan Fritsch 2012-02-26 16:59:41 UTC
fixed in 2.4.1