Bug 48136 - Essential files missing from source tarball
Essential files missing from source tarball
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.3.4
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-11-05 04:32 UTC by Onkar Shinde
Modified: 2010-01-09 10:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Onkar Shinde 2009-11-05 04:32:01 UTC
While packaging jmeter for Debian/Ubuntu, I observed that few essential files are missing from the source archive. I had to extract these files separately from the binary archive.

The list of files is:
bin/jmeter.properties
bin/saveservice.properties
bin/upgrade.properties
bin/jmeter-server

It will be great if this can be fixed in next release.
Comment 1 Sebb 2009-11-14 14:55:20 UTC
The binary archive contains everything needed for running JMeter. There should be no need to use the source archive at all.

Note that there are other source files which are only present in the binary archive currently, for example user.properties, system.properties. These also ought to be in any binary distribution of JMeter.
Comment 2 Onkar Shinde 2009-11-14 22:53:02 UTC
In most of the linux distributions the packages are built from source. But because of the files missing in source tarball, the resulting binary package is not complete and does not work out of box. Therefore I had to add these files as patch in the build process.

I hope the problem is clear now.
Comment 3 Sebb 2009-11-15 03:44:22 UTC
In order to build JMeter from source, you need to download both the source and binary archives, and unpack them in the same directory structure.

This is described in the README file.
Comment 4 Sebb 2010-01-09 10:07:39 UTC
Future releases will now contain all source files in the released source archive.

URL: http://svn.apache.org/viewvc?rev=897504&view=rev
Log:
Bug 48136 - Essential files missing from source tarball.