Bug 48311 - AprLifecycleListener: Bogus behaviour with Http11AprProtocol and java.library.path
AprLifecycleListener: Bogus behaviour with Http11AprProtocol and java.library...
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Native:Integration
5.5.28
PC Linux
: P2 critical (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2009-11-30 15:57 UTC by Hendrik Saly
Modified: 2010-01-30 11:46 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hendrik Saly 2009-11-30 15:57:09 UTC
This was originally bug 48300 but was lost in issues.a.o data loss on 2009-11-26/27 and re-created from the archives.

AprLifecycleListenes says "apr not found" but loads Http11AprProtocol connector

27.11.2009 21:07:45 org.apache.catalina.core.AprLifecycleListener lifecycleEvent INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-6-sun-1.6.0.16/jre/lib/i386/server:/usr/lib/jvm/java-6-sun-1.6.0.16/jre/lib/i386:/usr/lib/jvm/java-6-sun-1.6.0.16/jre/../lib/i386:/usr/lib/jvm/java-6-sun-1.6.0.16/jre/lib/i386/client:/usr/lib/jvm/java-6-sun-1.6.0.16/jre/lib/i386:/usr/lib/xulrunner-addons:/usr/lib/xulrunner-addons:/usr/java/packages/lib/i386:/lib:/usr/lib 27.11.2009 21:07:45 org.apache.coyote.http11.Http11AprProtocol init INFO: Initializing Coyote HTTP/1.1 on http-8080 27.11.2009 21:07:45 org.apache.coyote.http11.Http11AprProtocol init INFO: Initializing Coyote HTTP/1.1 on http-8443 27.11.2009 21:07:45 org.apache.coyote.ajp.AjpAprProtocol init
Comment 1 Hendrik Saly 2009-11-30 16:35:38 UTC
Seems that org.apache.tomcat.jni.SSL has no Field named TCN_MAJOR_VERSION as
expected in org.apache.catalina.core.AprLifecycleListener line 91-93.

This cause a java.lang.NoSuchFieldException: TCN_MAJOR_VERSION, caught by the
catch(Throwable t) in line 94 in org.apache.catalina.core.AprLifecycleListener.
APR gets loaded but worong message is generated: INFO: The Apache Tomcat Native
library which allows optimal performance in production environments was not
found on the java.library.path: /usr/lib ...
Comment 2 Hendrik Saly 2009-11-30 16:36:11 UTC
This was originally attachment ID 24631 that was lost as part of the issues.apache.org data loss on 2009-11-26/27.

Note that this attachment ID has since been re-used.

The original attachment comment was:

A first Patch
Comment 3 Mark Thomas 2009-11-30 16:36:54 UTC
The patch is in the wrong format. Please use diff -u.

Also, you are confusing this issue with bug 47712 which has already been fixed.
Comment 4 Hendrik Saly 2009-11-30 16:37:30 UTC
sorry for not seeing bug #47712

*** This bug has been marked as a duplicate of bug 47712 ***
Comment 5 Mark Thomas 2009-11-30 16:37:54 UTC
Again, you have misunderstood this bug. It is not at all related to bug 47712.
Comment 6 Hendrik Saly 2009-11-30 16:38:15 UTC
The only difference (related to bug 47712) i see is that APR get loaded even if
AprLifecycleListenes was commented out, right? The other problems seems solved
by fixing bug 47712. 

I had not reported the problem if I had found previously bug 47712
Comment 7 Mark Thomas 2009-11-30 16:38:42 UTC
Exactly. APR getting loaded even if the listener disabled is a bug. That is
totally separate from the issue with the APR listener described in 47712. The
only similarity between these bugs is that they are both to do with the APR
listener. There are two separate, independent bugs here.

This bug has already been fixed in trunk. I have proposed the fix for back port
to 6.0.x and 5.5.x.
Comment 8 Mark Thomas 2009-12-15 11:01:37 UTC
This has been fixed in 6.0.x and will be included in 6.0.21 onwards.
Comment 9 Mark Thomas 2010-01-30 11:46:05 UTC
This has been fixed in 5.5.x and will be included in 5.5.29 onwards.