Bug 48327 - cloneSheet() gives an "Error file: data may have been lost" in Excel 2003 or higher if sheet contains commented cells
Summary: cloneSheet() gives an "Error file: data may have been lost" in Excel 2003 or ...
Status: RESOLVED DUPLICATE of bug 47624
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.5-FINAL
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-02 01:30 UTC by Manuela
Modified: 2010-03-18 07:47 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuela 2009-12-02 01:30:27 UTC
Hi all :) 

I use a xls file as template and I need to copy a sheet and filling with data.
Following code:

HSSFSheet familyNameSheet = workBook.cloneSheet(2);

gives following error:

"Error file: data may have been lost"

when I try to open xls file with Microsoft Excel 2003 or higher.

OpenOffice opens file correctly.
Comment 1 Manuela 2009-12-03 02:28:35 UTC
I tried to cancel all comments and Excel opens file without pop-up-ing error message: "Error file: data may have been lost".
Comment 2 nothize 2010-03-18 07:47:00 UTC

*** This bug has been marked as a duplicate of bug 47624 ***