Bug 48564 - Allow to turn off retries for LB worker
Summary: Allow to turn off retries for LB worker
Status: RESOLVED DUPLICATE of bug 62408
Alias: None
Product: Tomcat Connectors
Classification: Unclassified
Component: mod_jk (show other bugs)
Version: 1.2.28
Hardware: PC Linux
: P2 enhancement (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-18 00:24 UTC by Ryszard Łach
Modified: 2018-08-23 18:31 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryszard Łach 2010-01-18 00:24:37 UTC
I cannot turn off retry for LB worker.

I'm not sure, but looking at jk_lb_worker.c it seems, that setting it to 0 won't help.

Look at the only place, where 'retries' is being checked

   while (recoverable == JK_TRUE) {
        lb_sub_worker_t *rec;
        if (attempt >= num_of_workers) {
            retry++;
            if (retry >= p->worker->retries) {
                /* Done with retrying */
                break;
            }

Should retry be checked only if attempt >= num_of_workers ?

Cheers,

R.
Comment 1 Rainer Jung 2014-12-22 20:11:07 UTC
I will mark this as an enhancement request.

The retries attribute of the LB is meant to control, how often the list of members will betried before giving up. So a "1" means, an LB will try each member at most once, a "2" (default) means, there will be at most two rounds of trying each member.

I will clarify the docs and think about whether a complete disabling of retries makes sense and how to implement it.
Comment 2 Mark Thomas 2018-08-23 18:31:01 UTC
Bug 62408 has a patch that should enable this to be addressed.

*** This bug has been marked as a duplicate of bug 62408 ***